Welcome to the Linux Foundation Forum!

DNS does not working

minherzminherz Posts: 3
edited March 27 in LFS260 Class Forum

Hi,
I have a problem with the two nodes cluster setup. I've followed the lab for in the Lesson 4 and have the cluster installed.
However, when I try to follow the instructions in the lab for the Lesson 5 (Exercise 5.3 - step 4) the curl command fails to resolve "kubernetes.default". The error is:

curl: (6) Could not resolve host: kubernetes.default
command terminated with exit code 6

The content of the resolv.conf is:

nameserver 10.96.0.10
search default.svc.cluster.local svc.cluster.local cluster.local us-central1-a.c.lf-kse-course-2021.internal c.lf-kse-course-2021.internal google.internal
options ndots:5

If I try to use dnsutils image and execute nslookup kubernetes.default then I get:

;; connection timed out; no servers could be reached

command terminated with exit code 1

However, the direct access to the API server by IP (10.96.0.1) works fine. It looks like some misconfig of the CoreDNS or the routing.
My cluster is created using GCP in the subnet with 10.0.2.0/24 CIDR. Firewall allows any TCP and UDP communication between two nodes and I run everything on the master node.

Comments

  • minherzminherz Posts: 3

    If I execute nslookup using one of CoreDNS pods' IP as a server, I get the same result i.e. "connection time out".

  • minherzminherz Posts: 3

    I found the problem. Apparently, my cloud environment was missing a firewall rule. Once all TCP, UDP, ICMP and IPIP was enabled for the cluster's node the problem get resolved. I used the calico instructions since the course instructions were less descriptive for me,

  • serewiczserewicz Posts: 870

    Great, glad you were able to troubleshoot the issue. And thank you for letting us know what happened.

    Regards,

Sign In or Register to comment.