Welcome to the Linux Foundation Forum!

Lab 13.1 needs to be updated for web-ui app cflinuxfs3 stack on anynines a9s

When deploying the web-ui app, I am attempting to stage the app but seeing an error for the anynines cloud foundry.

It relates to the manifest file specifying cflinuxfs2, whereas it appears this is outdated and cloud foundry on cflinuxfs3 will fail with this buildpack.

:/cloudfoundry-LFD232-course/class-artifacts$ cf restage web-ui

...

Staging app and tracing logs...
   Cell 353b6cd2-edd4-4469-a7d8-ddd4abe4aeb2 creating container for instance 6b05b294-63a2-4650-bda6-0761ee4388ff
   Cell 353b6cd2-edd4-4469-a7d8-ddd4abe4aeb2 successfully created container for instance 6b05b294-63a2-4650-bda6-0761ee4388ff
   Downloading app package...
   Downloaded app package (17.8K)
   It looks like you're deploying on a stack (currently set to *cflinuxfs3*) that's not supported by this buildpack.
   That could be because you're using a recent buildpack release on a deprecated stack.
   If you're using the buildpack installed by your CF admin, please let your admin know you saw this error message.
   If you at one point specified a buildpack that's at git URL, please make sure you're pointed at a version that supports this stack.
   Failed to compile droplet: Failed to compile droplet: exit status 44
   Exit status 223
   Cell 353b6cd2-edd4-4469-a7d8-ddd4abe4aeb2 stopping instance 6b05b294-63a2-4650-bda6-0761ee4388ff
   Cell 353b6cd2-edd4-4469-a7d8-ddd4abe4aeb2 destroying container for instance 6b05b294-63a2-4650-bda6-0761ee4388ff
   Cell 353b6cd2-edd4-4469-a7d8-ddd4abe4aeb2 successfully destroyed container for instance 6b05b294-63a2-4650-bda6-0761ee4388ff
Error staging application: BuildpackCompileFailed - App staging failed in the buildpack compile phase
FAILED

The manifest is stating to use cflinuxfs2, however it does not appear to respect the manifest setting for the stack.

Specifying the _-s cflinuxfs2 _override seems to indicate that there is no staging available for that stack. Possibly this stack has long been removed, so ** does the lab exercise needs to be updated?**

cf push ... -s cflinuxfs2
...
Applying manifest file web-ui/manifest.yml...
Manifest applied
Packaging files to upload...
Uploading files...
 17.75 KiB / 17.75 KiB [===================================================================================================================] 100.00% 1s

Waiting for API to complete processing files...

Staging app and tracing logs...
Unexpected Response
Response Code: 500
Request ID:    cc96f3e5-6da0-4e19-4929-de4992415b03::03dc764d-9f3f-4f41-9e8d-c6cbd72996fb
Code: 0, Title: , Detail: {
  "errors": [
    {
      "detail": "Stager error: no compiler defined for requested stack",
      "title": "CF-StagerError",
      "code": 170011
    }
  ]
}
FAILED

Switching to the latest buildpack will also fail, as Ruby 2.4.x is not available.

   -----> Ruby Buildpack version 1.8.30
   -----> Supplying Ruby
   -----> Installing bundler 1.17.3
          Download [https://buildpacks.cloudfoundry.org/dependencies/bundler/bundler-1.17.3-any-stack-b7502506.tgz]
          **ERROR** Unable to determine ruby: Unable to determine ruby version: Running ruby: No Matching versions, ruby ~> 2.4.0 not found in this buildpack
   Failed to compile droplet: Failed to run all supply scripts: exit status 15

The resolution here is to switch to an earlier buildpack version that still contains Ruby 2.4.x but also works on cflinuxfs3.

cf push the web-ui app with the flag -s cflinuxfs3 and updated manifest.yml below (noting to use version 1.8.15 of the buildpack)

---
applications:
- name: web-ui
  random-route: true
  buildpacks:
    - https://github.com/cloudfoundry/ruby-buildpack.git#v1.8.15
  memory: 128M
  instances: 1
  stack: cflinuxfs3

Positive outcome

name:              web-ui
requested state:   started
routes:            web-ui-*******.de.a9sapp.eu
last uploaded:     Thu 04 Feb 11:06:51 AEDT 2021
stack:             cflinuxfs3
buildpacks:        
    name                                                         version   detect output   buildpack name
    https://github.com/cloudfoundry/ruby-buildpack.git#v1.8.15   1.8.15    ruby            ruby

type:            web
sidecars:        
instances:       1/1
memory usage:    128M
start command:   rackup -p $PORT
     state     since                  cpu    memory      disk        details
#0   running   2021-02-04T00:07:06Z   0.0%   0 of 128M   0 of 512M  

Comments

  • Unfortunately it doesn't work for me. Can please someone update the files and documents for the course???

  • I apologize for the issue here. It appears the download for the class is pointing to the wrong version of the class artifacts. I have requested for the LF team to resolve this.

  • fcioancafcioanca Posts: 844

    The updates class-artifacts.tar file is now available online. Please follow the instructions provided on the Course Resources page in the introductory chapter to retrieve them.

Sign In or Register to comment.