Welcome to the Linux Foundation Forum!

Lab 4 needs newer version of Jenkins

Running Lab 4 using jenkins/jenkins:2.178-slim tag results in a lot of plugins failing due to Jenkins being an older version.

SSH Build Agents plugin version 1.31.2
You must update Jenkins from version 2.178 to version 2.190.1 or later to run this plugin.
Trilead API Plugin version 1.0.8
You must update Jenkins from version 2.178 to version 2.184 or later to run this plugin.

Tag jenkins/jenkins:2.222.4-lts-slim works well with the lab.

Comments

  • luisviveropenaluisviveropena Posts: 671

    Hi @ldaberko ,

    Yes, you can use a more updated image. I used jenkins:lts-slim and it works well. I think the instructor used that image only because it's lighter than "latest".

    Many regards,
    Luis.

  • @ldaberko feel free to use the latest version of jenkins/jenkins image. The versions keep on updating every few weeks. I will add a note in the instructions/lab.

Sign In or Register to comment.