Welcome to the Linux Foundation Forum!

Lab's settings

Hi,
I'm sorry for this question, but I'm new in these technologies.
I don't understand how setting my lab.
I have Ubuntu 18.04 on VirtualBox an I have installed Minikube to have Kubernetes in local.

What is it wrong in my lab's settings?
Because when I run the script k8sMaster.sh, for lab 2.2, I have some problem, e.g. how in this screenshot (in this momente Minikube is stopped).

Thank you for your patience.
Regards

Comments

  • chrispokornichrispokorni Posts: 669

    Hi,

    This course does not call for a Minikube installation. The course explores Kubernetes topics in multi-host environment setup, and that is not something supported by Minikube.

    Please follow the Kubernetes installation steps provided in the lab exercise.

    Regards,
    -Chris

  • Hi, thanks.
    The indications about how to set up the laboratory are not very clearly, at least for me :) .
    Therefore, the k8Master.sh and k8Second.h scripts run the nodes on the same VM, I must have two VM, first for master and secondo for worker or I must have a cloud support?
    I'm sorry for all these questions!

    Regards

  • chrispokornichrispokorni Posts: 669

    Hi @MariangelaPetraglia,

    You are correct, for lab exercises to successfully work, you need two VM instances. These instances can be cloud instances (AWS EC2 instances, GCE VMs, or DigitalOcean droplets, or others) or local VMs on a hypervisor of your choice (VirtualBox, KVM, or VMware).

    Keep in mind the instance size for resources: 2 CPUs and 8 GB RAM per instance, with Ubuntu 18.04 LTS. Also, disable all OS firewalls on your instances, and allow all inbound traffic from all sources, all protocols, to all ports at your infrastructure level (the cloud infra or local hypervisor).

    Regards,
    -Chris

  • Hi @chrispokorni,
    thank you so much for your explained.

    I removed Minikube from local istance. I executed k8Master.sh script on my local VM (Ubuntu 18.4.3 with VirtualBox) and then throw me this error (showed in screenshots below).


    The resource of VM are right(2 CPUs and 8GB RAM), I disabled firewall on the "istance" and allowed all traffic from all source.
    From what I understood, the kubeadm init is failed.
    What is the problem? I don't understand it.

    Thanks,
    Mariangela

  • tknoopstknoops Posts: 7

    how did you configure VirtualBox networking for the adapters? For this course "Bridged" seems the best option. If you have chosen NAT you'll have to set portforwarding for both machines which can be quite the hassle.

  • @tknoops said:
    how did you configure VirtualBox networking for the adapters? For this course "Bridged" seems the best option. If you have chosen NAT you'll have to set portforwarding for both machines which can be quite the hassle.

    I configured it with bridge.

  • Hi,
    I decided of remove the currently VM and configure a new VM.
    I don't know because the old VM not worked, but the configuration of a new VM works as aspected with k8sMaster.sh script. Therefore, at moment that problem I fixed it.

    Thanks you everyone.
    Regards
    Mariangela

  • chrispokornichrispokorni Posts: 669

    Hi,

    With VirtualBox, the promiscuous mode - allow all may have to be enabled for bridged networking.
    Also, I see you are using the default DHCP subnet of VirtualBox, which overlaps with the Pod subnet managed by Calico in your Kubernetes cluster. This will cause DNS and routing issues sooner or later, so I'd recommend changing your VirtualBox VM subnet to prevent overlapping with the 192.168.0.0/16 Pod subnet.

    Regards,
    -Chris

Sign In or Register to comment.