Welcome to the new Linux Foundation Forum!

preparation for LFS201 course

In preparation for running the LFS201 course/running labs, I downloaded the VM prebuilt image : OpenSUSE-Leap-15-1 and loaded it under VMware workstation realplayer 15. When I ran the ready-for.sh script (under my training login) it showed that i was ready to begin the course but also displayed a message indicating that some packages could be missing (so not clear whether these warnings are superfluous or ok to proceed with the course ?

Working on the assumption that we were missing some packages I ran ./ready-for.sh –install LFS201 which threw metadata errors below I note that the URL embedded links below within the script reference the non-secure http://download.opensuse.org/update/leap/15.1/non-oss/ url (which are inaccessible from any of our browsers)

However I note that I manually enter the secure URL https://download.opensuse.org/update/leap/15.1/non-oss/ url into my web browser. In place of http://download.opensuse.org/update/leap/15.1/non-oss/ I could access the content okay. I then updated the ready-for.sh script by changing http to https and reran with the result below. I’m assuming the issue lies with firewall restrictions associated with network connectivity through the VM but before I go ahead and investigate these restrictions, I just need someone to confirm whether the existing pre-built VM I’ve loaded should be suitablefor running the LFS201 course without the need for worrying about removing these restrictions /downloading any additional packages. ?

p.s please see attached file for associated screenshots.

Comments

  • coopcoop Posts: 309

    I confess I don't understand the problem. On my opensuse-15-1 VM (which is the basis of the one you downloaded) I don't get these problems. I gather your firewall/proxy may be interfering, but I have no suggestion to install the net-tools-deprecated package (in the script it is in the suggest category) and there are no references to any suse download site in the script, these are all picked up by zypper itself. So I cannot replicate any of your problems. I also don't understand where you "changed http to https" that it would matter in the script, there is no reference in any SUSE section I can find that would do that.

    So please elaborate if you think it would help.

    As far as that package goes, I'm sure it contains ifconfig, and that doesn't seem to be in my openSUSE VM either, I'll investigate where it went -- in earlier versions of openSUSE it was there. Maintainers have been overzealous exterminating ifconfig in favor of ip, which is foolish as some of us are used to using it and it is harmless probably

  • coopcoop Posts: 309

    actually the following command worked the second time:

    sudo zypper install net-tools-deprecated

    Have you made sure you have the newest version of ./ready-for.sh?

    I'll confess the opensuse VM tends to have some breakage, as perhaps 1 percent of students are using opensuse and it doesn't get as well debugged as a result. The LF also no longer offers the LFCS exam on that distribution either, which does not help in keeping it up to date. (once again, low usage and mutual agreement with the SUSE people.)

  • lee42xlee42x Posts: 118

    I did some checking on this this, I have some observations to add:

    The first attempt with zypper was like Coop's, it grumbled. It seems the VM server needed to update the ip address after opening the lid on the laptop. Everything works as expected on and after the second try.

    I poked at my proxy and firewall to see if there could be an issue and to devise a simple test. I came up with:
    http://httpvshttps.com it is a site comparing http and https. With my proxy engaged it blocks http traffic, disengaged it passes http and of course https works every time. This should show if there is any devices blocking the http traffic.

  • paoloc1paoloc1 Posts: 4

    Thanks for all the feedback provided. Please see my comments below.

    @coop said:
    actually the following command worked the second time:

    sudo zypper install net-tools-deprecated

    Have you made sure you have the newest version of ./ready-for.sh? > < Yes I am using the latest version.

    I'll confess the opensuse VM tends to have some breakage, as perhaps 1 percent of students are using opensuse and it doesn't get as well debugged as a result. The LF also no longer offers the LFCS exam on that distribution either, which does not help in keeping it up to date. (once again, low usage and mutual agreement with the SUSE people.)

    **< Given the issue/limitations with SUSE you highlighted above , I booted from the pre-built CENTOS 7 VM , reran all the checks, and all completed okay **

    The only issue I'm left with now is that my CAPs lock key doesn't seem to work in any of my Linux terminal window sessions running under VMware player, so had to cut and paste some of the case sensitive commands from the ready for LF course in order to complete pre-flight checks

    [[email protected] ~]$ ./ready-for.sh LFS201

    Checking that this computer is suitable for LFS201: Essentials of System Administration

    PASS: CPU architecture is x86_64
    PASS: 4 core CPU
    PASS: Your CPU appears powerful enough (currently at 15168 BogoMIPS cumulatively)
    PASS: 4 GiB RAM
    PASS: 18 GiB free disk space in /home/student
    PASS: 18144 MiB free disk space in /boot
    PASS: Linux distribution architecture is x86_64

    NOTE: Currently running CentOS Linux 7 (Core) (supported)

    PASS: All required packages are already installed


    PASS: You are ready for the course! W00t!
    NOTE: Make sure to follow the instructions above to fix any issues found
    [[email protected] ~]$

  • Hi @paoloc1 ,

    It looks to me that you are OK to go:

    ==> PASS: All required packages are already installed

    As the message says all the required packages are already installed. The note will appear anyway if your system passes all the requirements.

    Regards.

  • paoloc1paoloc1 Posts: 4

    @luisviveropena said:
    Hi @paoloc1 ,

    It looks to me that you are OK to go:

    ==> PASS: All required packages are already installed

    As the message says all the required packages are already installed. The note will appear anyway if your system passes all the requirements.

    Regards.

    Thanks. A final question for you. Will i require access to the network whilst running the labs associated with course LFS201 ?

    The reason i ask is that when I initially ran the pre-course checks from the pre-built Centos 7 VM, I also tested that I could ping/SSH to other IP (which worked fine). However i now find that although I can still ping other IP okay, there now appears to be some form of firewall restriction in place which is preventing me from using SSH through port 22 below . Also when I previously invoked firefox through same VM i was able to access all the pages on CentOS home screen , but when I try and connect i get a message attached saying that you must login to this network before you can access the internet , and when I try and open the network page i get an access denied error, so before i raise this issue with our Service desk/network team just wanted to clarify whether i will actually require network access through the VM during the labs or whether I am okay to proceed with the course ?

    p.s I received the errors below when trying to enable access to port 22 through firewall . I also tried the same test from a pre-built Ubuntu VM , but got the same errors and when I tried running sudo ufw allow 22/tcp --- i got message saying "skipping adding existing rule" ,"Skipping adding existing rule (v6)

  • coopcoop Posts: 309

    You can do about 90 percent of the course without network. However, there are chapters on networking. You also will not be able to update the VM with newly released package updates etc. So it would be good to sort out your problems which is also a learning exercise. However, you need not do that to start as the networking comes mostly later.

  • paoloc1paoloc1 Posts: 4

    many thanks for the feedback.

Sign In or Register to comment.