Welcome to the new Linux Foundation Forum!

Ubuntu VMWare Download - what version of VMWare is needed

I downloaded the Ubuntu-19-04 and I expanded and it loaded it into VMWare v14.1.4 Workstation and errored: "was created by a VMWare product that is incompatible with this version of VMWare Workstation and cannot be used"

The CentOS& VMWare worked without issue. Sadly I am not a Lunix person by trade and the course material is written for the Ubuntu version so the commands I need to look up. If I use that version I can avoid that and focus on the more important parts.

Thank you.

Comments

  • coopcoop Posts: 303

    Your vmware program is too old. The current version is 15.1.0. The 19.04 Ubuntu VM is a brand new one(I know, I created it!) and was created on a very recent version of vmware -- the CentOS7 was made quite some time ago but frequently brought up to date.

    You should just update the version (that is free, at least for the VMWare Workstation Player download) and all will be fine. Or if you are ambitious and like to live on the edge, go edit the .vmx file, as there is some version check in there (format I can't remember) which can be disabled or commented out and things are likely to be fine. But I would update instead as being easiest.

    However, if you use Ubuntu 19.04 for the course it may not be appropriate as the course was not developed for it. I'll let the LFS258 maintainers comment on this. Keep in mind things are geared for the LTS version, Ubuntu 18.04 as are the certification exams. If nothing else, the versions of various kubernetes packages may cause heartburn.

  • chrispokornichrispokorni Posts: 286

    Hi @prenticect,
    The lab installation instructions are calling for Ubuntu Xenial 16.04 LTS, so I would follow these instructions since the exercises have been designed and tested on that particular version. A VMware compatibility guide for guest operating systems would help you pick the right VMware Workstation version to install.
    Regards,
    -Chris

  • prenticectprenticect Posts: 21

    Thank you both. I will redownload the 16 version and then should also work with my VMWare instance :) So I learned two things. Thank you again.

Sign In or Register to comment.