Welcome to the new Linux Foundation Forum!

Prebuilt Centos7 VM images appear incompatible with Windows 10 Vmware Player nor Virtual Box

I'm running into issues running the provided VM's.

In Vmware Player it's saying the file is not compatible with the version of VMware Player I'm using. (12.5.9 build-7535481)

In virtual box, when I try to boot up the system I get the following error:

Could not boot.
/dev/disk/by-uuid/long list of characters/ does not exist

Entering emergency mode. Exit the shell to continue.

I am using 7zip to unzip the file and have verified the md5 checksums for the CentOS7.tar.xz file.

My next step is to create my own Centos 7 install and run the ready-for.sh. Is there anything this does not setup?

Who can I contact to get these VM's fixed?

Comments

  • lee42xlee42x Posts: 108

    I can make a suggestion on the VirtualBox issue. The virtual machine image is using a "scsi" disk connection for the disk image file, the default for VirtualBox is "sata". This can be easily fixed in the VirtualBox configuration. First delete the disk and adapter from the VirtualBox configuration then add a new adapter that is "scsi" this time and finally re-attach the disk image file. It should start properly now. I did test these steps with VirtualBox on Linux and the issue/solution was as documented.
    Lee

  • Hi PhilipBecker,

    I'm not aware of that error, I'll look into it. BTW, ready-for.sh should install the most of the software you need. And if anything is missing, you can install it using the utilities of the distro, it's not that difficult to do and you will do it anyway in the labs.

    If you find any problem installing your own CentOS 7 machine please let us know.

    Regards,
    Luis.

  • coopcoop Posts: 283

    You are also ruuuning a rather old version of vmplayer. I have 14.1.3
    ot
    these kinds of problems (SATA vs SCSI, hypervisor and OS etc) happen from time to time and we cannotoffer comprehensive tech support on this. However, this VM has been used by many people just fine and it was actually built using VMPlayer so that should not be an issue

    I am pretty sure Lee has the right answer here though. Seen it before rarely.

  • lee42xlee42x Posts: 108

    Just to confirm, I verified that the CentOS7 image functions correctly with Windows10/VirtualBox using both 7zip and winzip to extract the downloaded files. I did have to change the adapter type to SCSI.

  • lee42xlee42x Posts: 108

    I verified the vmplayer on Windows10 works with the CentOS image. The current version of vmplayer is 15. The vmplayer does not need any changes to the storage configuration but I had to reduce the memory size and number of cpu's as I have a smaller machine than the one used to create the VM.

  • Thanks everyone for your help. The very old version of Vmware player was the issue and the sci/sata was the issue with VirtualBox.

    Thanks again!

  • coopcoop Posts: 283

    yes, the version dependence has come up before. They don't try very hard to make vm's backward compatible, but it is usually ok unless it is a rather old vmplayer version

Sign In or Register to comment.