Welcome to the new Linux Foundation Forum!

problem with Wireless

tonjaatonjaa Posts: 19

i use Ubuntu 9.04 motherboard Asus P5K-E WIFI-AP Solo

Ethernet controller : Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit .

i want to use Wireless of motherboard for share network but i can't install driver from cd it's for windows how i can use Wireless ?

if it have driver for Ubuntu please guide to me .

i try to add Wireless from network connection but i can't to do it.



  • amnesiaamnesia Posts: 60

    I noticed there was a 'linux' section under Downloads -- maybe there's something there you can use.

    Others (1)
    File Size 12.45 (MBytes)

    I downloaded the Linux drivers
    it has everything you need.
  • You need to check as to what type of wireless card you have. You listed the ethernet controller, not the wireless LAN card. To do that in Ubuntu open up the console and issue the command:

    sudo lshw -C network

    It will return information about your card types. You should see one listed with Wireless LAN controller in the list. That will tell you the type and then you can check specifically for which driver you need.

    Also, with Ubuntu if you go to "System -> Administration -> Hardware Drivers" you can check for and install proprietary drivers...Ubuntu will handle all of that if it has the correct driver in the repository.

    If you want to use your Windows driver you can. Check the Ndiswrapper doc/howto in the Ubuntu community pages:


    Hope that helps!
  • tonjaatonjaa Posts: 19
    i use command - sudo ls -c network i get this
    [email protected]:~$ sudo lshw -C network
    [sudo] password for tonjaa:
    description: Ethernet interface
    product: 88E8056 PCI-E Gigabit Ethernet Controller
    vendor: Marvell Technology Group Ltd.
    physical id: 0
    bus info: [email protected]:02:00.0
    logical name: eth0
    version: 12
    serial: 00:1e:8c:60:4e:1f
    size: 100MB/s
    capacity: 1GB/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.22 duplex=full firmware=N/A ip= latency=0 link=yes module=sky2 multicast=yes port=twisted pair speed=100MB/s
    description: Wireless interface
    physical id: 1
    logical name: wlan0
    serial: 00:15:af:51:9c:97
    capabilities: ethernet physical wireless
    configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
    *-network:1 DISABLED
    description: Ethernet interface
    physical id: 2
    logical name: pan0
    serial: d6:68:ec:72:42:86
    capabilities: ethernet physical
    configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

    and i try to Install the ndisgtk package but i don't know it correct or not . i can't use wireless like same time .
    i back to find cd driver of motherboard i fine folder Linux driver
    i saw folder WIFI and have 2 folders name
    - debian31-8187(110) and linux 26x-8187(110)
    at folder of debian31-8187(110) has 4 fils
    this is driver of wireless or not if it's driver how i can install it ?
  • amnesiaamnesia Posts: 60
    it has a Readme ?
  • tonjaatonjaa Posts: 19
    this file readme .txt [file name=ReadMe.txt size=3194]http://linux.com/media/kunena/attachments/legacy/files/ReadMe.txt[/file]
  • amnesiaamnesia Posts: 60
    yeah, you should read that
  • tonjaatonjaa Posts: 19
    i try to use command ./load but it can't insert modules like this

    [email protected]:~/Desktop$ cd module
    [email protected]:~/Desktop/module$ ls
    ieee80211_crypt_ccmp-rtl.ko ieee80211_crypt-rtl.ko ieee80211_crypt_tkip-rtl.ko ieee80211_crypt_wep-rtl.ko ieee80211-rtl.ko load r8187.ko unload
    [email protected]:~/Desktop/module$ ./load
    insmod: error inserting 'ieee80211_crypt-rtl.ko': -1 Operation not permitted
    insmod: error inserting 'ieee80211_crypt_wep-rtl.ko': -1 Operation not permitted
    insmod: error inserting 'ieee80211_crypt_tkip-rtl.ko': -1 Operation not permitted
    insmod: error inserting 'ieee80211_crypt_ccmp-rtl.ko': -1 Operation not permitted
    insmod: error inserting 'ieee80211-rtl.ko': -1 Operation not permitted
    insmod: error inserting 'r8187.ko': -1 Operation not permitted
    SIOCSIFFLAGS: Permission denied
    [email protected]:~/Desktop/module$

    what 's wrong how i can do it ?:huh:
  • amnesiaamnesia Posts: 60
    You may not have support compiled into the kernel..
    You may not be running the commands from root..
    [email protected]:~/ < root?

    to mount/umount a kernel module -- you need root.

    1. Unpack source code of WPA supplicant:
    tar -zxvf wpa_supplicant-0.3.8.tar.gz
    cd wpa_supplicant-0.3.8

    2. Create .config file:
    cp defconfig .config

    3. Edit .config file, uncomment the following line:

    4. Build WPA supplicant:

    -- you said you wanted to make it an 'access point' ?
    you need to cd /usr/src/linux-2.x.x.x
    ls -la | grep .config
    if that's a good config
    cp .config ../
    make mrproper && make distclean
    cp ../.config $PWD

    make oldconfig && make menuconfig

    -> Device Drivers -> Network Device Support ->
    look around.. you May find your driver or generic support : )
    'Wireless LAN support'.. might be worth doing this
  • tonjaatonjaa Posts: 19
    thank you very much .
  • Goineasy9Goineasy9 Posts: 1,116
    I have an Asus Mobo M2N32 Deluxe (wireless edition). When I purchased it I thought I could get the wifi working with Linux. It works like an access point, which I thought would be an interesting edition to my home network. I tried the 8187 driver (sorry, don't remember which one, but was never able to get it working properly. The disk that comes with the motherboard contains drivers, which I tried with ndiswrapper. I tried many 8187 drivers when using Debian and still didn't have luck. Maybe the Asus forums could help, but I think a Linux driver for this dongle is not available. Below is the info for the chip:

    Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

    If anyone has any luck finding a driver that works with this, please let me know, I'd be happy to try it out.
  • tonjaatonjaa Posts: 19
    on Ubuntu i try to install ndiswrapper by command
    sudo apt-get install ndisgtk
    and i find driver windows .inf for Realtek RTL8187 at first time
    i think it's PCI type but i wrong. i find on web
    http://rtl8180-sa2400.sourceforge.net/ it's tell spec is USB.
    and i find driver from web
    then i add driver from windows wireless driver it's can use
    in ad-hoc mode but it not have access point mode for choose .
    i think it's ok . even through it's not good same use program on
    windows i hope next time Linux can use all program from windows
    thank you .;)
  • For the realtek drivers, you can also find it from here: https://www.driverdr.com/drivers-download/
Sign In or Register to comment.