Welcome to the Linux Foundation Forum!

LAB 3.1 - This site can't be reached

lenzandylenzandy Posts: 6

lab3.1 () Status: Ready

but when I go to login to IP address from "ip addr show eth0"

I get "This site can't be reached"

this has happened twice now over about 40 min.  how can I use this course if it takes 40 min to even login?


  • serewiczserewicz Posts: 918
    edited December 2016

    Has your ./stack.sh script finished without issue? Are there any errors during the script? Are you using the public IP address or an internal facing IP address (192.168.x.y)?


  • yemisishobowaleyemisishobowale Posts: 11
    edited December 2016

    I have the same  issue been trying for two days now. ./stack.sh script finished without issue. Based on your response above, are we to change the Host IP and eth2 to the publich IP of eth0. Please specify what exactly needs to be changed in the local.conf file to access the Horizoon BUI successfully. See my local.conf file below and output of ip addr show eth0 .

    [email protected]:~/devstack$ cat local.conf




    FIXED_RANGE= #Range for private IPs


    FLOATING_RANGE= #Range for public IPs








    [email protected]:~/devstack$

    [email protected]:~/devstack$

    [email protected]:~/devstack$

    [email protected]:~/devstack$  ip addr show eth0

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group d

    efault qlen 1000

        link/ether bc:76:4e:04:a3:4c brd ff:ff:ff:ff:ff:ff

        inet brd scope global eth0

           valid_lft forever preferred_lft forever

        inet6 2001:4800:7810:512:be76:4eff:fe04:a34c/64 scope global

           valid_lft forever preferred_lft forever

        inet6 fe80::be76:4eff:fe04:a34c/64 scope link

           valid_lft forever preferred_lft forever

    [email protected]:~/devstack$


  • yemisishobowaleyemisishobowale Posts: 11
    edited December 2016

    Continuation of previous post: Forgot to mention, I have tried to to unstack.sh and clean.sh and re-run the stack.sh script several times today. Still the same issue. Either i get the "This site Cant be reached error" or the apache page, when attempting to access Horizon BUI.  Back in September I could access the BUI, but not in the last two days.

  • serewiczserewicz Posts: 918
    edited December 2016

    The public IP, to access the node, is set prior to creation of the local.conf file. There is no need to edit that line as it represents what the OpenStack cloud will share as Floating IP addresses. 

    You would use the address you pasted above. 

    As I asked, did the installation complete without error? I beleive if you look at the log file it did not. As there is an error, and it indicates an exit, you would not see the horizon GUI.

    The issue appears to be with the software git repo from DevStack. I will investigate why it is not showing properly. Until the ./stack.sh script finishes properly you could not expect to see a horizion gui.


  • yemisishobowaleyemisishobowale Posts: 11
    edited December 2016


    Ran the unstack.sh and clean.sh scripts, removed the devstack directory as I have done a couple of times in the last few days and executed the stack.sh script.

    git clone https://git.openstack.org/openstack-dev/devstack -b stable/liberty

    As recommended I checked the logs and yes, there were errors, see below:


    2016-12-23 10:40:31.175 | + timeout=0

    2016-12-23 10:40:31.175 | + timeout -s SIGINT 0 git clone git://git.openstack.org/ope

    nstack/cinder.git /opt/stack/cinder

    2016-12-23 10:40:31.177 | Cloning into '/opt/stack/cinder'...

    2016-12-23 10:40:52.692 | + cd /opt/stack/cinder

    2016-12-23 10:40:52.701 | + git checkout stable/liberty

    2016-12-23 10:40:52.701 | error: pathspec 'stable/liberty' did not match any file(s)

    known to git.

    2016-12-23 10:40:52.701 | + exit_trap

    2016-12-23 10:40:52.701 | + local r=1

    2016-12-23 10:40:52.701 | ++ jobs -p

    2016-12-23 10:40:52.701 | + jobs=

    2016-12-23 10:40:52.701 | + [[ -n '' ]]

    2016-12-23 10:40:52.702 | + kill_spinner

    2016-12-23 10:40:52.702 | + '[' '!' -z '' ']'

    2016-12-23 10:40:52.702 | + [[ 1 -ne 0 ]]

    2016-12-23 10:40:52.702 | + echo 'Error on exit'

    2016-12-23 10:40:52.702 | Error on exit

    2016-12-23 10:40:52.702 | + generate-subunit 1482489409 243 fail

    2016-12-23 10:40:53.134 | + [[ -z /opt/stack/logs ]]

    2016-12-23 10:40:53.134 | + /home/ubuntu/devstack/tools/worlddump.py -d /opt/stack/lo


  • dalym1234dalym1234 Posts: 6
    edited January 2017

    Hi has this been resolved?  I am seeing the same issue.

  • serewiczserewicz Posts: 918
    edited January 2017

    Some of the liberty release software is available, but not all of it. As a result the install will fail. I have been working on Newton labs and they have been writen. Once the infrastrucure team tests and updates they will be available. 

  • dalym1234dalym1234 Posts: 6
    edited January 2017

    This has been broken for the best part of 4 weeks.

  • dalym1234dalym1234 Posts: 6
    edited January 2017

    Sorry to sound like a broken record but this is still not working, and I would like an ETA of when I might expect it to be restored.

  • serewiczserewicz Posts: 918
    edited January 2017

    As far as I have heard the necessary updates will be coming through soon. An actual date/time I cannot give, but very soon. You have not been forgotten. Thank you for your patience. 

Sign In or Register to comment.