Welcome to the new Linux Foundation Forum!

Lab 4.1

i'm running ubuntu 14.4 on virtual box and "fake_service" wont start.

it returns the error

"cant touch '/var/lock/subsys/fake_service' : no such file or directory"

...it seems my /var/lock directory only contains one sub directory "whoopsie" .

help!

Comments

  • coopcoop Posts: 261
    I ran a VM on vmware for Ubuntu 14.04 and repeated exactly all the steps in the
    lab and it all worked perfectly. and the lock file existed. I would suggest you
    step back through things. In particular make sure:

    1) you have sysvinit-utils and chkconfig packages installed.

    2) make sure you created /etc/default/fake_service *AND* modified fake_service to
    point to it instead of /etc/sysconfig

    3) make sure you do all the starting/stopping as root (sudo)

    Other than that I don't really know.
  • munzalimunzali Posts: 3
    edited October 2015
    thanks, wasn't able to install chkconfig program (somthing about the package no longer being available) but i made some modifications to the fake_service script
    (removed the parts of it that were trying to access /var/lock which isn't present in my file system(...for whatever reason) ) and used the invoke-rc.d and update-rc.d commands instead of chkconfig.


    NEW PROBLEM WITH LAB 4.2

    systemctl command not found on my system!
  • coopcoop Posts: 261
    You don't say what distro and version you are running. If you are running any ubuntu earlier than 15.04 you will not have systemctl (or any systemd stuff). I think it is mentioned in the course (but I'm not sure) that chkconfig is not availaible on Ubuntu 14.04. This stuff is very distro and version dependent and you just have to figure it out. We can't give you every exact detail on each one. Fortunately, you were sharp enough to work it out for your situation!
  • Ahh yes! That was mentioned.
    Thanks.

    I'm using ubuntu 14.04
  • Hi!!
    In Ubuntu Server 14.04, I have create the /var/lock/subsys or /run/lock/subsys directory (/var/lock is a symbolic link to /run/lock) and the service worked fine.
  • vamvam Posts: 6
    edited December 2015
    had same problem with script on Ubuntu 14.04
    There is no chkconig package on 14.04 and I had sysvinit-utils installed.
    $ sudo service fake_service start
    Running fake_service in start mode...
    touch: cannot touch ‘/var/lock/subsys/fake_service’: No such file or directory
    

    service started after
    $ sudo mkdir /var/lock/subsys
    

    Not sure if subsys directory would not be gone after reboot.
  • jesusojesuso Posts: 2
    edited December 2016

    I was able to stop/start the fake_service, but I was not able to add it with chkconfig. Did you have same issue? what am I doing wrong? Note: As you can see using CentOS7 and VirtualBox 

    [[email protected] ~]$ sudo chkconfig --add fake_service

    service fake_service does not support chkconfig

    [[email protected] ~]$ sudo systemctl enable fake_service

    fake_service.service is not a native service, redirecting to /sbin/chkconfig.

    Executing /sbin/chkconfig fake_service on

    service fake_service does not support chkconfig

    [[email protected] ~]$ /sbin/chkconfig fake_service on

    service fake_service does not support chkconfig

    [[email protected] ~]$

     

     

  • luisviveropenaluisviveropena Posts: 296
    edited December 2016

    Hi Jesuso,

    It worked here at once:


    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 14.0px Menlo; color: #ededed; background-color: #000000}
    p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 14.0px Menlo; color: #ededed; background-color: #000000; min-height: 16.0px}
    span.s1 {font-variant-ligatures: no-common-ligatures}

    [[email protected] default]# chkconfig --list fake_service 

     

    Note: This output shows SysV services only and does not include native

          systemd services. SysV configuration data might be overridden by native

          systemd configuration.

     

          If you want to list systemd services use 'systemctl list-unit-files'.

          To see services enabled on particular target use

          'systemctl list-dependencies [target]'.

     

    service fake_service supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add fake_service')

    [[email protected] default]# chkconfig --add fake_service 

    [[email protected] default]# 

    [[email protected] default]# cat /etc/redhat-release 

    CentOS Linux release 7.2.1511 (Core) 

    [[email protected] default]# 

Sign In or Register to comment.