Welcome to the new Linux Foundation Forum!

How to dual-boot Ubuntu with Windows 10 installed first?

Im new to Linux distros, and im doing a security save of my laptop. Now, i have some questions, like if the file system is managed the same, if i can directly pass files through windows and ubuntu, how programs work on linux... I wanted to know, apart of that, how i can boot Ubuntu 64 bit and Windows 10, due that Windows is bugging alot. Any help out there?

Thanks,

TheCrimulo

Comments

  • I'm new too, so I don't have any real answers. I have seen some videos on YouTube that have that as an option. On my laptop it is just Chromixium. My main computer is newer and shipped with Windows 10. I'm having issues with the UEFI Bios, as I can't even run a live DVD (black screen), and I used it to install it on the laptop. I want a Linux Distro as the main OS on my desktop as well (possibility run Windows 10 from a virtual machine). Still trying to figure that one out. Anyway.... Check YouTube as it might help you get a duel boot setup.
  • I'm new too, so I don't have any real answers. I have seen some videos on YouTube that have that as an option. On my laptop it is just Chromixium. My main computer is newer and shipped with Windows 10. I'm having issues with the UEFI Bios, as I can't even run a live DVD (black screen), and I used it to install it on the laptop. I want a Linux Distro as the main OS on my desktop as well (possibility run Windows 10 from a virtual machine). Still trying to figure that one out. Anyway.... Check YouTube as it might help you get a duel boot setup.

    UEFI booting is what is causing your black screen. This could be corrected by going into your BIOS, (usually del key or F1, varies by manufacturer). Going under boot options and either changing from UEFI to Legacy. And/or by turning off secure boot (if you change to legacy mode secure boot will automatically be disabled). However, doing that will causes Windows to not boot. Basically, what i do when i want to run a live CD is go into bios, change it to legacy mode, change boot order so the USB boots first, do whatever i want in the LIVE CD, then when i'm done, go back into bios and change back to UEFI/CSM, and restore the boot order to hard drive. It's not an ideal solution, but some linux distros have problems with UEFI booting, or it requires a bit more work to create a UEFI-capable liveCD.
  • This video might help both of you.

  • I'm new too, so I don't have any real answers. I have seen some videos on YouTube that have that as an option. On my laptop it is just Chromixium. My main computer is newer and shipped with Windows 10. I'm having issues with the UEFI Bios, as I can't even run a live DVD (black screen), and I used it to install it on the laptop. I want a Linux Distro as the main OS on my desktop as well (possibility run Windows 10 from a virtual machine). Still trying to figure that one out. Anyway.... Check YouTube as it might help you get a duel boot setup.

    UEFI booting is what is causing your black screen. This could be corrected by going into your BIOS, (usually del key or F1, varies by manufacturer). Going under boot options and either changing from UEFI to Legacy. And/or by turning off secure boot (if you change to legacy mode secure boot will automatically be disabled). However, doing that will causes Windows to not boot. Basically, what i do when i want to run a live CD is go into bios, change it to legacy mode, change boot order so the USB boots first, do whatever i want in the LIVE CD, then when i'm done, go back into bios and change back to UEFI/CSM, and restore the boot order to hard drive. It's not an ideal solution, but some linux distros have problems with UEFI booting, or it requires a bit more work to create a UEFI-capable liveCD.

    Thanks! My UEFI is a lot different then the ones I've found tutorials on. I have played with ROMs for android, but this is really all very new to me. The desktop is ASUS M32cd and the UEFI is version 502. The ability to turn off secure boot is turned off, and so much seems to be hidden in other menus. I'm trying to learn what settings need to be changed, and have found a few resources. The laptop was easy, because of the old style BIOS.I'm so ready for it (the desktop) to be running Linux, but I want to make sure I don't mess something up in the UEFI because I'm not knowledgeable enough.
  • This video might help both of you.


    Thank you. My UEFI looks much different than that, and so are the available options. I definitely appreciate the help, I can use all I can get as I'm learning this stuff.
  • xgraystorm01xgraystorm01 Posts: 12
    edited February 2016
    Yeah, different computer makers make different options available in BIOS, or sometimes name things differently. Without actually seeing what options are available on your computer's BIOS boot menu options, i can't help you with the exact options that would need to be changed. As i said though, turning off UEFI would only be good to use a live disc, and would not work for actually installing a linux distro (Not if you want to dual boot with windows 10). This tutorial here can walk you thru creating a UEFI-only install disc for Ubuntu, maybe try making this UEFI-only Ubuntu and see if you can boot it.
    I have also read that some BIOS have an option called fast boot, which needs to be turned off.

    http://askubuntu.com/questions/395879/how-to-create-uefi-only-bootable-usb-live-media/

    Hope some of this helps
  • Thanks! I'll take some pictures of it. Just turning off fast-boot gets me black screen. If I enable CSM and have it set to UEFI/Legacy or just legacy, I can get it to start reading the live DVD, but once past the LM boot logo there is script that is running to fast to read, It seems to be the same set of something over and over. That is where it hangs up.I know this Linux Mint works, as I used it on the laptop today (and did check MD5 after downloading). There is something I'm missing, I know it,just not sure what it is. I have tried setting it to Other OS,but same thing as before,some sort of error script that I can't read. I'm sure it will all make more sense with image to reference.
    Yeah, different computer makers make different options available in BIOS, or sometimes name things differently. Without actually seeing what options are available on your computer's BIOS boot menu options, i can't help you with the exact options that would need to be changed. As i said though, turning off UEFI would only be good to use a live disc, and would not work for actually installing a linux distro (Not if you want to dual boot with windows 10). This tutorial here can walk you thru creating a UEFI-only install disc for Ubuntu, maybe try making this UEFI-only Ubuntu and see if you can boot it.
    I have also read that some BIOS have an option called fast boot, which needs to be turned off.

    http://askubuntu.com/questions/395879/how-to-create-uefi-only-bootable-usb-live-media/

    Hope some of this helps
  • Here are some images of my UEFI and one of the running errors.
    Yeah, different computer makers make different options available in BIOS, or sometimes name things differently. Without actually seeing what options are available on your computer's BIOS boot menu options, i can't help you with the exact options that would need to be changed. As i said though, turning off UEFI would only be good to use a live disc, and would not work for actually installing a linux distro (Not if you want to dual boot with windows 10). This tutorial here can walk you thru creating a UEFI-only install disc for Ubuntu, maybe try making this UEFI-only Ubuntu and see if you can boot it.
    I have also read that some BIOS have an option called fast boot, which needs to be turned off.

    http://askubuntu.com/questions/395879/how-to-create-uefi-only-bootable-usb-live-media/

    Hope some of this helps
  • xgraystorm01xgraystorm01 Posts: 12
    edited February 2016
    Ok.
    Try this first by just turning off fast boot.

    The black screen issue, and possibly the error messages you see may have something to do with your video card. This article discusses the black screen with mint and instructions on possibly fixing it. http://community.linuxmint.com/tutorial/view/842

    When you get the Linux Mint boot menu, highlight Linux Mint 17 and press the tab key to edit the boot parameters, look for the line that starts with Linux, somewhere in the line (it wraps the text so actually spans multiple lines) you should see quiet splash, delete both of those and at the end of the line type in nomodeset. Then press CTRL+X to boot with the changed parameters. Removing quiet and splash will get rid of the mint logo, and allow you to see all kernel messages while it boots up.

    If the first thing doesn't work. i would test changing the BIOS option "Boot from storage device" to UEFI and Legacy instead of just legacy only. This could also be a reason for the black screen
    EDIT: Sorry i should have mentioned that Ubuntu and Mint are both Debian based distros, so the article i listed should work for ubuntu as well as Mint
  • Thank you for all your help. I agree that a hardware issue is most likely. I started my own thread, as I have since hijacked this one, with a better description of what I have tired and the errors I'm getting. I will try to edit the line next. Thank yo again! I'm started to get very frustrated and feeling like I'll never have it up and running on the desktop (outside of a VM).
    Ok.
    Try this first by just turning off fast boot.

    The black screen issue, and possibly the error messages you see may have something to do with your video card. This article discusses the black screen with mint and instructions on possibly fixing it. http://community.linuxmint.com/tutorial/view/842

    When you get the Linux Mint boot menu, highlight Linux Mint 17 and press the tab key to edit the boot parameters, look for the line that starts with Linux, somewhere in the line (it wraps the text so actually spans multiple lines) you should see quiet splash, delete both of those and at the end of the line type in nomodeset. Then press CTRL+X to boot with the changed parameters. Removing quiet and splash will get rid of the mint logo, and allow you to see all kernel messages while it boots up.

    If the first thing doesn't work. i would test changing the BIOS option "Boot from storage device" to UEFI and Legacy instead of just legacy only. This could also be a reason for the black screen
    EDIT: Sorry i should have mentioned that Ubuntu and Mint are both Debian based distros, so the article i listed should work for ubuntu as well as Mint
  • I had that problem but after my sister messed with her BIOS didn't have it any more but I have no clue what she did and I don't think she does either. Anyway now I have another problem with Linux installer identifying Windows 10. I am 10 times less computer savy than most of you. Please find thread and help.

  • saqman2060saqman2060 Posts: 777
    edited August 2016

    What exactly is the problem you are facing? Does the installer idenfy the Windows partition or does it just list partitions on the disk? It should at least give the type of partition like NTFS or FAT. Most likely, those partitions belong to Windows.

Sign In or Register to comment.