Welcome to the new Linux Foundation Forum!

Lab 3.2 openstack installation issue

Trying to install openstack on compute-node with local.conf from Labs and Solutions.pdf. Got an "exit 1" with listed missing parameters:

OS_USERNAME, OS_AUTH_URL, OS_PROJECT_NAME, OS_DOMAIN_NAME

I've tried to add these parameters to the local.conf like this:

 OS_USERNAME=admin

OS_AUTH_URL=http://$SERVICE_HOST:5000/v2.0

 OS_PROJECT_NAME=demo

 OS_DOMAIN_NAME=Default

However, after unstack, clean and install I've got exactly same errors.

 

Thank you,

 

 

Comments

  • serewiczserewicz Posts: 467
    edited June 2016

    Hello,

    The stack.sh script went through some iterations where the settings were not being set as they should. The upstream repo should have been updated so this is no longer an issue. If you find the error again, please run the command: source openrc admin  prior to running the ./stack.sh script again. That will set the necessary parameters.

     

  • aroudikaroudik Posts: 3

    OK. Tried "source openrc admin" and got the following:

    2016-06-23 06:00:24.523 | +lib/nova:create_flavors:924               openstack --os-r

    egion-name=RegionOne flavor list

    2016-06-23 06:00:25.826 | Discovering versions from the identity service failed when

    creating the password plugin. Attempting to determine version from URL.

    2016-06-23 06:00:25.828 | Unable to establish connection to http://192.168.97.2:5000/

    v2.0/tokens

    2016-06-23 06:00:25.888 | +lib/nova:create_flavors:926               openstack --os-r

    egion-name=RegionOne flavor create --id c1 --ram 256 --disk 0 --vcpus 1 cirros256

    2016-06-23 06:00:27.211 | Discovering versions from the identity service failed when

    creating the password plugin. Attempting to determine version from URL.

    2016-06-23 06:00:27.213 | Unable to establish connection to http://192.168.97.2:5000/

    v2.0/tokens

    2016-06-23 06:00:27.274 | +lib/nova:create_flavors:1                 exit_trap

    2016-06-23 06:00:27.281 | +./stack.sh:exit_trap:480                  local r=1

    2016-06-23 06:00:27.289 | ++./stack.sh:exit_trap:481                  jobs -p

    2016-06-23 06:00:27.296 | +./stack.sh:exit_trap:481                  jobs=

    2016-06-23 06:00:27.302 | +./stack.sh:exit_trap:484                  [[ -n '' ]]

    2016-06-23 06:00:27.309 | +./stack.sh:exit_trap:490                  kill_spinner

    2016-06-23 06:00:27.316 | +./stack.sh:kill_spinner:376               '[' '!' -z '' ']

    '

    2016-06-23 06:00:27.322 | +./stack.sh:exit_trap:492                  [[ 1 -ne 0 ]]

    2016-06-23 06:00:27.329 | +./stack.sh:exit_trap:493                  echo 'Error on e

    xit'

    2016-06-23 06:00:27.329 | Error on exit

    2016-06-23 06:00:27.336 | +./stack.sh:exit_trap:494                  generate-subunit

     1466660833 794 fail

    2016-06-23 06:00:27.651 | +./stack.sh:exit_trap:495                  [[ -z /opt/stack

    /logs ]]

    2016-06-23 06:00:27.658 | +./stack.sh:exit_trap:498                  /home/ubuntu/dev

    stack/tools/worlddump.py -d /opt/stack/logs

    2016-06-23 06:00:28.102 | +./stack.sh:exit_trap:504                  exit 1

    [email protected]:~/devstack$

    Thanks for your time

  • aroudikaroudik Posts: 3

    OK. I've changed FLAT_INTERFACE to eth0 and still got the following error:

    2016-06-24 18:48:24.831 | Unable to establish connection to http://192.168.97.2:5000/

    v2.0/tokens

    I wonder if anyone thought to take a working devstack copy and put it into a separate Git repository to avoid all these troubleshooting issues?

     

    Thanks,

     

  • serewiczserewicz Posts: 467

    Hello,

    A couple of questions to help me troubleshoot with you. Which step are you trying to complete? Does this error happen when you select the "start over" button and start a fresh lab instance?

    The 192.168.97.2 instance is the compute-node instance. The stack.sh script should be sending the request to the first host, which is running the keystone service. Please double check that in Lab 3.2, task 1, step 2 the HOST_IP is set to 192.168.97.2 and  FIRST_HOST=192.168.97.1

    Regads,

Sign In or Register to comment.