Welcome to the new Linux Foundation Forum!

Lab 11.1 - Task 3.9 - "health HEALTH_ERR" instead of "HEALTH_OK"

Despite following all the related steps, the problem I met is that I got an health HEALTH_ERR while checking Ceph cluster configuration via 'ceph -s', meaning that there is an error in the Lab 11.1 commands I gave. See the "CLI record - Lab 11.1 - health HEALTH_ERR" snapshot.



 

Comments

  • mixtzinmixtzin Posts: 4

    Cannot upload the snap due to "You are not authorized to access this page."

  • serewiczserewicz Posts: 479
    edited July 2016

    Working with a distributed object storage system can be difficult to troubleshoot. If you look at the ceph-deploy output on each node, were there any errors. There are a lot of warnings as well, but errors tend to be the first indication of an issue. 

    If there are no errors try to restart the OSD nodes. With replication enabled the inability to copy over the node can cause objects to back up and eventually not be able to serice requests. A restart would allow the components to start fresh and you could tell if the issue is transient or a configuration issue. To see the status of the cluster you can querey the monitors. This page explains how:   http://docs.ceph.com/docs/master/rados/troubleshooting/troubleshooting-mon/

    If the error persists and the monitors don't indicate the issue, perhaps you can copy and past the output as text and we can try to troubleshoot further.

     

  • mixtzinmixtzin Posts: 4
    edited August 2016

    Hi,

    here [ https://1drv.ms/u/s!An_BsSsMhAWEglOfn4vKOjp_pK-L ] you can find attached a simple .html file, that records my full CLI session. You can open with any browser, once downloaded.

    Once opened, press the 'play' button to repoduce the CLI record I typed. You can also use the sliders to move the CLI record across the time and even increase the related speed.

    Despite following all the related steps (documented in the CLI record), the problem I met is that I got an health HEALTH_ERR to check the configuration, meaning that there is an error in the Lab 11.1 commands I gave. See the "CLI record - Lab 11.1 - health HEALTH_ERR" snapshot.

    Not sure, but the problem might be due to the error, got at the beginning (~ minute 10th) , while trying to upgrade rdo-cc, as asked in the Task1. Or, most probably, after typing "ceph-deploy osd activate storage1:/var/local/osd0 storage2:/var/local/osd1"  (~ minute 55th), when I got the following error:

    ...

    [storage1][WARNIN] ceph_disk.main.Error: Error: ['ceph-osd', '--cluster', 'ceph'


    , '--mkfs', '--mkkey', '-i', '0', '--monmap', '/var/local/osd0/activate.monmap',


     '--osd-data', '/var/local/osd0', '--osd-journal', '/var/local/osd0/journal', '-


    -osd-uuid', '49590f07-ef48-48fb-8881-b46afec19d02', '--keyring', '/var/local/osd


    0/keyring', '--setuser', 'ceph', '--setgroup', 'ceph'] failed : 2016-07-06 11:17


    :31.904999 7fb142e60800 -1 filestore(/var/local/osd0) mkfs: write_version_stamp(


    ) failed: (13) Permission denied                                                


    [storage1][WARNIN] 2016-07-06 11:17:31.905024 7fb142e60800 -1 OSD::mkfs: ObjectS


    tore::mkfs failed with error -13                                                


    [storage1][WARNIN] 2016-07-06 11:17:31.905095 7fb142e60800 -1  ** ERROR: error c


    reating empty object store in /var/local/osd0: (13) Permission denied           


    [storage1][WARNIN]                                                              


    [storage1][ERROR ] RuntimeError: command returned non-zero exit status: 1       


    [ceph_deploy][ERROR ] RuntimeError: Failed to execute command: /usr/sbin/ceph-disk -v activate --mark-init systemd --mount /var/local/osd0 

    Thanks for your kind support.

     

  • serewiczserewicz Posts: 479
    edited August 2016

    Hello,

    After investifation it seems that the deploy script cannot work in the /var/local/osd0 or osd1 directory. If you run a chown ceph.ceph /var/local/osd0 on storage1 and /var/local/osd1 on storage2 systems you should be able to activate the OSDs.  

    I will update the course material to reflect this update.

    Thank you for bringing it to our attention.

  • mixtzinmixtzin Posts: 4

    Hello,

    you are welcome! Hope to be helpful for someone else ;)

    FYI, I found the related issue on the tracking system, now in Closed statuts: http://tracker.ceph.com/issues/13833



     

  • serewiczserewicz Posts: 479
    edited August 2016

    Thanks mixtzin for helping out!

Sign In or Register to comment.