Welcome to the new Linux Foundation Forum!

LFS201 Lab 10.1 problem on CentOS7-VMWARE

CoemgenCoemgen Posts: 10
edited July 2015 in LFS201 Class Forum

I followed the steps in the Lab 10.1 Solution but the OS would not reboot.

To troubleshoot, I restarted the VM and used Grub to add verbose to the kernel line. This time I was prompted for a password for the encrypted partition. I entered the password and the boot sequence completed.

Is this how it should work?

The OS I am running is CentOS7-VMWARE (on VMWare Player) from:

http://training.linuxfoundation.org/cm/VIRTUAL_MACHINE_IMAGES/

Comments

  • I ran the lab on centOS-6.6-VMWARE and didn't need to add anything to the GRUB menu. My Vm booted up and prompted for a password before bringing up the normal login screen
  • coopcoop Posts: 284
    This lab was probably only tested on CentOS6, not CentOS7. They are rather different at least in the sense RHEL6 uses Grub 1, RHEL7 uses Grub 2. However, i reviewed all the official red hat instructions for RHEL7 and the only thing that is not right is there should be a third argument of "none" in /etc/crypttab, i.e.,

    secret-disk /dev/sda4 none

    to encourage it to prompt for a password. However I don't think this is the problem. Also, I do not know what you mean by you added "verbose" to the kernel command line as that is not a normal kernel parameter.

    Anyway, if anyone knows the answer fine, let us know. Otherwise we'll investigate, it is time consuming and we'll start by trying fedora, ubuntu etc.
    Thanks for bringing this to our attention
  • CoemgenCoemgen Posts: 10
    I got "verbose" from: https://wiki.archlinux.org/index.php/Boot_debugging#Light_Debug

    I'll try adding "none" as the third argument in /etc/crypttab and update the thread with the result.
  • coopcoop Posts: 284
    "none" did not help me, and adding "verbose" to the kernel command line actually made things worse somehow.

    "verbose" is *not* a kernel parameters AFAIK; all of them are listed in DOcumentation/kernel-parameters.txt in the kernel source, and in kernel documentation parameters, and developers are pretty careful to put all parameters in that document, do that they are all explained and can be used. (I should search the source, but it will be hard to find where a parameter such as that is parsed). However, any parameter not understood by the kernel is passed to "init" (in this case systemd-init) and I have to see what that does with the parameter.

    In any case, it did not work for me anyway. So I'll take this as homework, but I'm rather busy right now, might even be a week or weeks before I can think about it.
  • CoemgenCoemgen Posts: 10
    When I added the "verbose" parameter to the kernel line I may have been booting into the 4.1.0 kernel instead of the 3.10.0-229.7.2.el7.x86_64 kernel. I'll try doing the lab again but this time boot into the 4.1.0 kernel.
  • CoemgenCoemgen Posts: 10
    No, I'm having trouble booting the 4.1.0 kernel too.
  • CoemgenCoemgen Posts: 10
    edited November 2015
    deleted
Sign In or Register to comment.