Welcome to the Linux Foundation Forum!

open the shell

fenicsfenics Posts: 3
edited October 2014 in Command Line

Hi. I just installed the slackware 14.1. how do i oper the terminal? because i click up the desktop on the left on the K icon, type "terminal" and it opens a window. why i see bash4.2 instead of "my [email protected]?"

Comments

  • By default Slackware won't set many different options in your shell.

    In your ~/.bashrc you would want to set:
    if [ "$BASH" ]; then
      PS1='\[email protected]\h:\w\$ '
      alias ls='ls -F'
      alias pico='nano';
    else
      if [ "`id -u`" -eq 0 ]; then
        PS1='# '
      else
        PS1='$ '
      fi
    fi
    

    If you are using zsh, in your .zshrc you might set:

    PROMPT="${at_normal}${fg_lgreen}%[email protected]${at_underl}%m${at_underloff}${fg_white} [${fg_cyan}%~${fg_white}]:${fg_white%}%b$reset_color
    ${fg_white}[${fg_green}%T${fg_white}]:${fg_lgray} "
Sign In or Register to comment.