Welcome to the Linux Foundation Forum!

USB wi-fi adapter?

DanaDana Posts: 5

This is my first experience with Linux, and the person who sold me the computer won't answer my emails. I have a Dell Inspiron 531, running the Linux OS Ubuntu 12.04, and i need a USB wi-fi adapter that's compatible with it. Two different stores have sold me adapters they said would work, but neither of them has. Can someone who actually KNOWS tell me what USB adapters(s) is/are compatible with my system? Thank you.


  • mfillpotmfillpot Posts: 2,180
    There are some adapters that work without issues, but they generally are not marked as such. I have found that the usb wifi that sony sells for their smart TVs works perfectly, but it is expensive. I also found some at newegg such as http://www.newegg.com/Product/Product.aspx?Item=N82E16833116003 that say they are compatible.
  • FigueiridoFigueirido Posts: 3
    Thank you for your reply.
    I have used a USB adapter to connect to my WiFi using Mint. But I wanted the complete wifi experience using the laptop wifi and not a adapter. I persisted in trying different distros running them from Live CD first and came across CHAKRA, the laptop wifi card worked immediately so I am now dual booting Chakra and windows.
    Thank you
  • absal0mabsal0m Posts: 6
    I am glad to hear your problem was solved. For future reference I have always found this wireless card compatible and have always used it when I have wireless issues. Sadly I have not found good resources that link people to compatible wireless cards, but I hope one day every card will be compatible.

    Here is the link: http://support.netgear.com/product/WG111v3
  • DanaDana Posts: 5
    Unfortunately, the problem is not as solved as i thought; i got the adapter yesterday, and my system says, "Command line output: End-of-central-directory signature not found. Either this file is not a zipfile or it constitutes one disk of a multi-part archive."
  • absal0mabsal0m Posts: 6
    What did you do before you got that message? Also for wireless issues you may want to check out ndiswrapper
  • mfillpotmfillpot Posts: 2,180
    What action did you take prior to getting the message? I am asking because the message is indicating that an archive extraction failed. If you were trying to use an adapter that is supported by the kernel no such action would be necessary, so that would indicate that you are either trying to to use ndiwrapper or a third-party driver.
  • DanaDana Posts: 5
    I'd put the Diamond adapter's accompanying CD into the CD drive and gotten a window that included something like
  • mfillpotmfillpot Posts: 2,180
    Windows based drivers do not work on linux based systems, so the autorun is meaninless. You can attempt to use the ndiswrapper application to translate the driver, due to the wide documentation of ndiswrapper I will not give the steps here as a quick google search will find the necessary instructions.

    Have you just tried going to the network connection applet and checking to see if it already sees the new device?
  • roobalroobal Posts: 25
    If you have some usb adapter or adapters, write on which chipset it works. If you will buy some usb adapter, look for working on Atheros chipsets, there is most probability that it will work out of the box.

    Make sure also that you have installed usb_modeswitch packet.
  • DanaDana Posts: 5
    Thanks to all of you who offered advice; i'll add some further advice: Don't believe everything Radio Shack workers tell you about their products.
    The problem has been solved in the best way possible -- i'm now in a house where i can get DSL and don't need wi-fi.
Sign In or Register to comment.