Welcome to the Linux Foundation Forum!

Problem with downloads on Fedora 17 64 bit

petersonlevi88 Posts: 52
edited August 2012 in Fedora

I can download, but cannot run. It says it is saving in downloads, but when it completes, it is somewhere else. A window that pops up when download is complete, but I cannot do anything with it. If I close this window, file can never be again unless I start up browser window and click downloads. I have tried to download several things. I have decided to abandon Fedora for the moment and am attempting to get Zorin 6 64 bit as the os. It won't even let me save file to disc or usb flash drive. Help please.


  • Also, I have tried dif download managers and dvd burner apps. None will let me choose the burner drive as a save location and when I pull up my file manager, it does not even show the drive or any others. They are active though cause when I insert media in, it recognizes. Help please, for I am stuck. Thank you.
  • mfillpot
    mfillpot Posts: 2,177
    That sounds like some of the applications or libraries on your system are corrupt, did you verify the md5sum when you originally downloaded the iso for Fedora? if not that may explain some of the issues. For right now I recommend continuing to attempt to install zorin to see if it fixed the issue, if the issue persists then it must be hardware related, although that is very unlikely.
  • Thank you very much. Installed Ubuntu and working fine. Going to attempt zorin install from Ubuntu. Curious is all. I've seen things on youtube that interest me. I have Ubuntu on my more powerful PC running a 3GHz dual core and I love it. Silverlight Cert sites are my only problem such as Netflix. Gonna try Brazil server Netflix and see if that works. LOL
  • mfillpot
    mfillpot Posts: 2,177
    Netflix does not currently work on Linux based computers (except chromebooks), this is because it uses silverlight and some proprietary DRM libraries. They have been promising support for two years ans are supposedly going to release it later this year for other Linux based operating systems. As of now there is no work around except running it on windows.


Upcoming Training