Welcome to the new Linux Foundation Forum!

Dell Studio 1745 Drivers

BarterBarter Posts: 3

Hi I am new to Linux and have recently installed a copy of Ubuntu 12 onto my Dell Studio 1745 multiboot with a copy of Windows 7 Pro.

I currently have no sound at all from the speakers or headphones so I don't think I have the audio driver installed. So my question really is where can I find these drivers and how do I install them?

Any help would be greatly appreciated!

Thanks

Chris

Comments

  • BarterBarter Posts: 3
    I'm not sure if it helped but I added

    options snd-hda-intel in the /etc/modprobe.d/alsa-base.conf

    When I go to System settings - Audio It changes from Speakers to Headphones as I plug them in and out and I do now have sound from the internal speakers but still nothing out of the headphone jack!?

    Chris


  • mfillpotmfillpot Posts: 2,180
    The lack of headphone sound may be due to the drivers not being up-to-date. I had a similar issue a while ago and just waited for the updates that eventually fixed the problems.
  • Goineasy9Goineasy9 Posts: 1,116
    I have a Dell Studio 17 and the sounds works out of the box. Did you make sure that all the volume sliders are up and enabled. Ubuntu uses PulseAudio. Search in your package manager for paprefs, paman and pavucontrol and install them. Then look through each to see if everything needed is enabled. By default, some of the hardware is disabled until you switch it on. You should also be able to switch the output device from the internal speakers to the earphones from within PulseAudio. Those 3 utilities make it easier to configure.
  • Whatever u tried was good, but have u run this command: sudo alsa force-reload after modifying etc/modprobe.d/alsa-base.conf file..... if this will not work, simply restart the ubuntu ! Remember, sometimes the headphone jack has it's own mute + level settings. Which might only be available in alsamixer. Try to look here:
    $ cat /proc/asound/cards
    $ amixer
    $ alsamixer

  • BarterBarter Posts: 3
    Hi thanks for your replies I tried installing paprefs , paman and pavucontrol but cant find any settings in there that look like they should disable it. I will have another play later and let you know how I get on!

    Thanks


    Chris
Sign In or Register to comment.