Welcome to the Linux Foundation Forum!

Network interface is not recognized

Dear All

I searched a lot about my problem, but I have not found any solution about it. Would you please tell me what can I do or where should I ask this question?

I'm trying to install ZeroShell on a ClearBox(model: CAR-3000) but Zeroshell can not identify the network interface and says "No Network Interface".

I found no drivers for ClearBox network interface, so tried to install them, by copying /lib/modules files from ClearOS to Zeroshell, it did not work either.

Is there anyone who knows what should I do?


  • mfillpotmfillpot Posts: 2,180
    Can you please post the output of the command "uname -a" here so that we can identify the kernel and base system used on that appliance?
  • farzadmbfarzadmb Posts: 5
    The whole results of running "uname -a":
    Linux zeroshell.example.com #1 SMP Thu May 14 23:12:00 CEST 2009 i686 GenuineIntel unknown GNU/Linux
  • mfillpotmfillpot Posts: 2,180
    edited April 2012
    Since you output has verified that it is a Linux based system, then the network card should be visible to all applications, so I would assume that the problem would be with the application or application configuration. I have no experience with zeroshell, so I think you should ask users of the application.

    Have you tried asking the question in the zeroshell forum (http://www.zeroshell.net/eng/forum/) to get their input?
  • farzadmbfarzadmb Posts: 5
    The OS can not recognize the Interface. It's a command base OS on server and when I want to see the interfaces, it says there is no interface!
    Yes, I have posted on so different forum, includes that, but I have no got any answer yet.
    Is there any global way to find drivers on an OS and copy them to another?
  • mfillpotmfillpot Posts: 2,180
    Thank you for that response, that gives much more information. You can use the "lspci -vvv" to list all motherboard and pci based hardware including the names of the kernel modules being used for each device. If the network card is not being recognized by the OS then it was not compiled into the kernel, which indicate that it was assumed to not be needed or that no kernel drivers are not available. If you can figure out the hardware chipset information for the lspci command then I will do my best to assist in locating the drivers.
  • farzadmbfarzadmb Posts: 5
    It's so nice! ZeroShell does not have lspci command! It is removed from OS! But it would not help me if ZeroShell had lspci, because OS can not detect driver to show it as the result of this command. Should I install ClearOS on the system to detect the driver?!
    Isn't there any way to copy all the drivers of network from ClearOS to ZeroShell and ZeroShell detects the right one and use it?
  • mfillpotmfillpot Posts: 2,180
    You cannot just copy the drivers, they must be compiled against the running kernel. I have spotted occurrences in the zeroshell forum where people are getting lspci output, have you considered compiling and installing it yourself?
  • farzadmbfarzadmb Posts: 5
    Sorry, you're right! I don't know what mistake I made before that thought lspci does not exist! But it does not help! Compiling linux is difficult and I was looking for an easier solution. I tried to edit image of ZeroShell and replace drivers, but it does not work and there is no easier solution than compiling it again!
    Thanks for your help.
  • fifi30fifi30 Posts: 9
    edited April 2019

    If the network card is not being recognized by the OS then it was not compiled into the kernel, https://xender.pro/ https://discord.software/ https://omegle.onl/

Sign In or Register to comment.