Welcome to the Linux Foundation Forum!

Lab 10.1 - VM doesn't survive reboot


VMware Workstation 10

CentOS 7

When following the Lab 10.1, after last step (9 - reboot), VM isn't loading again.


  • coop
    coop Posts: 915
    This lab really should say test before trying the reboot thing, say by doing

    sudo mount -a

    after modifying /etc/fstab. If it were me, I would reboot and get into emergency
    mode (surely when you say isn't loading again you mean that I hope, it starts to boot
    and then can't load the encrypted partition). Then I would comment out the line in /etc/fstab that loads that partition, reboot again and then when things are fine try to mount it maually with whatever parameters were in fstab. (to edit fstab in emergency mode, or single mode, you may have to do mount -o rw,remount / first.)

    If it is failing to boot at all you have me stumped.

  • shustr
    shustr Posts: 5
    I did "mount -a" and actually the /secret folder is mounted after that (you can create files in there, etc)

    On my VM after passing GRUB there is output which usually VM is passing successfully and starts to load the system. But in this case it stuck on that output (screenshot attached).

    I could load in emergency mode but although under root I couldn't edit /etc/fstab - it's in read only.

    Tried to replicate working on different runlevels - same result.
  • coop
    coop Posts: 915
    To repeat:

    " (to edit fstab in emergency mode, or single mode, you may have to do
    mount -o rw,remount /
    first.) "
  • shustr
    shustr Posts: 5
    Well, I'm just reporting an issue I could replicate when following the lab's task...

    Anyway, following up with this, I want to add that I couldn't replicate the issue on newer kernel version.

    System couldn't load after reboot on: 3.10.0-229.e17.x86_64
    However, when followed the lab on newer kernel 3.10.0-327.10.1.e17.x86_64 the system rebooted without issues and asked password phrase for the /secret

    May be it will be useful for someone.
  • luisviveropena
    luisviveropena Posts: 1,163

    That kernel version may be buggy. Something similar happened here, same kernel version (3.10.0-229): http://unix.stackexchange.com/questions/208321/fresh-centos-7-1-install-continually-boots-into-emergency-mode

    But in that case it was a physical machine, so they got a console message with a call trace that you may not be getting in the vm.



Upcoming Training