Welcome to the new Linux Foundation Forum!

Lab 26.1 - Any tips for doing the lab? I don't see any messages of OOM-killer in my logs :-(

I did as the lab required. I have some issues with this lab and don't have an idea how to deal with that.

I switch off the swap as required.

I use free to see how much free virtual memory I have.

Then I start the stress program with appropriate parameters. If I choose to stress requesting more memory than is available the stree program won't even start, and it simply finishes with an error message.

If I request more or less as much memory as there is available then the program starts and finishes without issues, but I cannot see any entry of the OOM-killer in my logs; I checked /var/log/dmesg and /var/log/syslog and /var/log/kern.log.

I verified the following:

/proc/sys/vm/oom_kill_allocating_task has the value 0

/proc/sys/vm/panic_on_oom has the value 0

I expected the OOM-killer to show up in one of the log files, but unfortunately I cannot find an entry anywhere in the system.

Any help is appreciated. How did you guys go about this? Did it work in your case?

I use Ubuntu 15.04, but I have the same problem with CentOS 7.

Comments

  • coopcoop Posts: 260
    "If I choose to stress requesting more memory than is available " is where you probably went wrong. You probably had page cache memory which could be freed without causing the system to truly run out.

    If you ask for very large amounts the system is smart enough to give up. What you need to do is if you have say 4 GB of mem, ask for 4 GB (or 3.8 GB or so) as that can not be satisfied and keep everything else running. if you were to ask for 20 GB it would probably just tell you nope.

    To see the oom messages you can do "dmesg -w" (or look at system logs)
  • ElyasElyas Posts: 28
    Thanks, I think I got it now.
    I had to do it iteratively in order to see OOM-killer in the log. dmesg -w was a good recommendation.

    First free reported there was about 200M free memory. So I started stress with -m 1 --vm-bytes 200M. The program started and finished without problems.
    I checked free again and it had a bit more than 300M memory available; not sure where that came from. So I started stress with more than 300M as parameter. stress started and finished without issues again.
    This time free showed about 400M free memory. I changed the stress parameter again and OOM-killer showed up in the log.
Sign In or Register to comment.