Welcome to the new Linux Foundation Forum!

[Help] lab 34.1 Glitch group permissions or inheriting permissions affecting folder access?

After creating the users and groups at the end of the lab even after adding bullwinkle to the bosses group and giving group ownership, bulwinkle still cannot create a file under the somedir folder.

PS: at first I thought it had to do with the guid number so I changed the ownership to friends to test if it worked.

IMAGE(http://i.imgur.com/KJN04bh.png)

Comments

  • Also the version is 3.10.0-327.3.1.el7.x86_64 CentOS
  • bump
  • coopcoop Posts: 283
    I was able to run all the steps in the SOLUTIONS for this lab on RHEL 7 and it worked fine with one minor exception: the command
    sudo groupadd -g 490 bosses
    borks because group 490 belongs to libvirt; the lab must have been developed on a system without libvirt. So just drop -g 490; it is totally un-needed anyway, I don't know why it was put there.

    In the solutions, file creation fails after step 5 but works after step 6 (as it should).

    Can you try cutting and pasting the solution commands into the command line and see if it works exactly as such? (you should remove rocky and bullwinkle first or use new users of course, as well as their groups)

  • I deleted them and I tried again with groups > 1000 and I still get the same error.

    I guess that if in exam date there is no such a glitch I will be happy.
  • coopcoop Posts: 283
    The groups greater than 1000 was not the problem. The reason 490 was excluded had to do with libvirt. There was no need to use the -g option at all, I don't know why it was in the lab except to show how to set a group number.


    I can not reproduce your problems on the same distro. Therefore I cannot help. If someone else has the same problem they can comment. Please make sure you repeat the steps in the solution to the lab in the exact way it is done (with that change as noted in previous post) and let us know if it still fails. If it succeeds compare with what you did. Also make sure you don't have anything left over with these groups and users before you start,
    i.e., use userdel and groupdel first.
Sign In or Register to comment.