Welcome to the Linux Foundation Forum!

FYI Lab 10 module activation step is missing CentOS7 cryptsetup

rchenzheng Posts: 36

After trying to mount my encrypted partition for hours and looking through the solutions, it does not state anywhere that you need to load the module :S

Went through emergency mode one too many times.

For those who are having the same problem, you will need to check if the module is loaded upon boot by doing:

lsmod | grep dm_crypt

if nothing comes back it, you will need to create a script at /etc/sysconfig/modules/dm_crypt.modules

with the following:



modprobe dm_crypt


Give it permissions: chmod 755 dm_crypt.modules


  • luisviveropena

    1) What distro and version are you using?
    2) Please provide the kernel version in use:

    uname -r

    3) Please provide the specific commands you ran.

  • rchenzheng
    rchenzheng Posts: 36
    edited December 2015

    CentOS 7.

    Those are the exact commands I ran besides the ones in the lab.
    Make sure you do it before doing the lab or you won't be able to boot as it will not understand and will not timeout.

    PS: the new lab updates did not include this, I guess they expected us to know from the lab of kernel modules.
  • coop
    coop Posts: 915
    There are a number of ways to deal with not having something loaded, depending on the situation.

    If you are doing a custom kernel you can build this in and then modprobe is not only not needed it won't do anything. But assuming you are using a stock distro kernel, problems can arise because you were not using encryption originally and now you are. If you had been using it when you installed the system, the encryption module would have been part of the initramfs image and that behaviour would have continued as you upgraded kernels. The system is not smart enough to figure this out on its own, depending on distro and version. It's possible that next time you build an initramfs (say through a kernel upgrade) it would get built in because it is loaded at the time of the upgrade. You can also update /etc/dracut.conf to tell it to build in the initramfs.
  • KristyBenoit13
    KristyBenoit13 Posts: 3
    edited April 2016

    I ran into this same issue.  All the information leading up to the labs say something to the effect of "if LVM is set up this is easy" but nothing said how to tell if it is or isn't, nor what to do if it isn't. A little "oh by they way, if this crashes your system here is why and how to fix it" would have been nice.  Even after backing out the changes in /etc/fstab and /etc/crypttab, I must remove the encrypted jump drive from the system or it will still fail to boot.  I figured out, with much frustrated and despterate googling, that I was missing a module but by then I was far too frustrated stay up for two more hours to test to see if that resolved the issue (and get the system to boot agian if it didn't).  I'll be trying again tonight, now that the module has been installed.

  • luisviveropena
    luisviveropena Posts: 1,163


    What distro and version are you working with? Having a module that has not been loaded is a common problem on linux administration; be sure that you will need to google for more complicate things than this. Something pretty different on linux is that the student/administrator must to be able to solve somethings by himself. And this is a good way to learn it.

    If you still consider that we need to add some information, please tell us what level of detail would be useful.

    BTW, I remember when I was new to linux that I changed the permissions of /etc so I could see the all the files in there. As result of that, I was unable to boot the system and I run to get a friend who helped me to solve the issue. It was a kind of funny thing because it was a shared system between some other students in the university!!

    Since that time I had many other issues that I had to deal with. So be sure you will as well.




Upcoming Training