Welcome to the new Linux Foundation Forum!

Can't get Atheros USB wifi adapter to work on Linux Mint 17.2

Hi,

I've used windows for almost 20 years, but am considering moving to linux. I wanted to play around with it so I installed Mint 17.2 32 bit w/Xfce desktop on an old Dell Inspiron 1520 laptop. The laptop stopped recognizing its onboard wifi card a couple of years ago (while still a windows machine) but has worked fine with a USB adapter since then. However, now that I've installed Mint I can't get the adapter to work, I can't even get the computer to detect it.

I've read through quite a lot of similar situations online and tried to take the steps that others took, but I can't get it to work. Actually, the very first distro I installed was Mint 17.2 Cinnamon 64 bit (uninstalled because computer wasn't powerful enough), and I did somehow get the adapter to work, but (as ridiculous as this will sound) didn't realize it at the time and I tried quite a lot of things, so I'm not sure what actually worked. The good news is, the port will currently recognize a USB flash drive, the wifi adapter will work in another machine, and as I just said, I was able to get it to work once, so I would think all the hardware is ok.

The adapter is pretty old, it has the Atheros AR5007 chipset, which (from what I read) I think requires the ZD1211 driver. I checked the firmware folder and it's in there, but that doesn't seem to help. When I enter lsusb and lspci the device doesn't show up. I've tried various other things, including ndiswrapper, to no avail. If anyone has any ideas on how I might get this to work I would greatly appreciate it.

Thanks,

Scott

Comments

  • Well, after getting the adapter to work for a third time without realizing it, I'm pretty sure the issues I've been having are more related to me being a noob than any hardware problems. Most recently I got the adapter to work by doing a clean install, running update manager, and issuing a sudo modprobe command for both zd1211rw and ath5k. I did not delete any files or install any new ones. It would appear that, while the drivers came with the distribution, for whatever reason the modules weren't loading at startup.

    To get the onboard card to work I did have to go to another website (google "broadcom 4311 linux driver," it's the first result, I'm not allowed to post the link yet) and follow the instructions for the b43 module, but once I did it worked no problem. I'm still pretty surprised the onboard card works at all, like I said it hasn't worked for years as a windows machine, the bios didn't even find it, but whatever, it's back. Even with ath5k, zd1211rw, and b43 all loaded everything works, I can choose between 2 wireless and 1 wired connection.

    I don't feel particularly smart at the moment, but hopefully this helps someone else figure their own issues out.
Sign In or Register to comment.