Welcome to the Linux Foundation Forum!

problems installing group packages on Oracle Linux 7.1 (el7uek.x86_64)


Hi All,

I am a newbie to Linux and I would like to have some help regarding installation of software group packages on Oracle Linux 7.1. I did a minimal install of the OS and also installed Compatibility Libraries as an Addon. Amongst other settings, I disabled SELinux ad the firewall, updated all packages using yum update and added EPEL release 7.5 to yum. Next, I did a yum update ato update all packages and then yum grouplist to see the available packages and started installing required packages using yum groupinstall command.

Now some packages like Additional Development could not be installed because I did not install mariadb-devel packages. Questions: What's the best way to install mariadb? Will SQL 5.6 do the same job?

The main issue I found is I could not install many packages like Console Internet Tools, General Purpose Desktop, Compatibility Libraries, Java Platform, NFS File server and so on. I can see these packages are in the available groups list but when I try to install, yum does not find any packages to install for these packages. Question: What I am missing here? Why can I use yum to install some packages but not others?

I redownloaded the public yum repo file and then tried to install but that did not help.

I also tried mounting the iso file for Oracle Linux 7.1 (downloaded from the oracle website), created a repo file for yum to use the iso file while disabling all other repo files and tried to install the packages but that didn't help either.

I then downloaded the public-yum-ol6.repo repo file and enabled it while disabling other repo files. This time yum did find packages to install but there were version issues obviously.

So the question is why does yum finds no packages to install for these packages groups when using public-yum-ol7 repository. What am I missing here?

Thank you for your help.




Upcoming Training