Welcome to the new Linux Foundation Forum!

Jenkins behind SSL, my case not going through

sndltsndlt Posts: 8
edited July 2015 in System Management

I used to use these statemets to put Jenkins behind reverse proxy for TLS in previous previous job. But somehow these are't working anymore.

I referred to all the Jenkins proxy guides on here and and Jenkisn website, but no luck. They all seem to have variations of what I already have/know down in conf files.

So basically, I installed Jenkins and can access via http://its-address:8080; Now I'm triyng to put it reverse proxy through http:its-address so that I can reverse proxy it to https://its-address

I used to able to get through without using a2enmod.

These are what I used to add on httpd.conf and ssl.conf.

[httpd.conf]

<VirtualHost *:80>

DocumentRoot /var/www/html

ProxyPass / http://localhost:8080 / nocanon

ProxyPassReverse / http://localhost:8080/

ProxyRequests Off

ProxyPreserveHost On

<Proxy http://localhost:8080/*>

Order deny,allow

Allow from all

</Proxy>

</VirtualHost>

[ssl.conf]

SSLProxyEngine On

ProxyPreserveHost on

ProxyPass / https://localhost:8080

ProxyPassReverse / https://localhost:8080

No matter what I do around syntax, I'm suffering from

httpd[2410]: AH00526: Syntax error on line 100 of /etc/httpd/conf/httpd.conf:

httpd[2410]: ProxyPass|ProxyPassMatch needs a path when not defined in a location

or

httpd[2401]: Invalid ProxyPass|ProxyPassMatch parameter. Parameter must be in t...lue'.

Am I putting the correct statements?

Seems like I'm not even puting it behind 80 to be able to forward to 443. 443 is currently configured with CA signed keys and the test page is secured.

Help appreciated, thanks.

Sign In or Register to comment.