Welcome to the Linux Foundation Forum!

ATI Radeon-Radeon hybrids

armandrix Posts: 1

Hi Everybody,

I'm having a strange behavior of my notebook graphics. It's an MSI gx-60 (do NOT recommend to anyone, except to my foes), with Amd A-10 4600m with hd7970m discrete card.

I always, whenever possible, prefer to use xorg/dri drivers for my machines. Since the purchase of it I'm using Archlinux and it's been working very well until some updates ago, when suddenly it becomes to use integrated gpu as default.

The only thing I need is just use the discrete gpu (do not want change it i.e. for battery saves, etc), but I can't.

At boot it uses discrete gpu in 2 moments: 1 in bios boot, second after grub to X. After graphical session is started, about 3 to 5 seconds, it is still using discrete gpu but than it changes to the Integrated one and stay so.

To fix that, I had to install fglrx and use amdcccle to choose the default gpu.

I have tried out to install: Opensuse, Debian (wheezy, jessie), Mint, Xubuntu and Fedora in a spare partition, all with the same results according the age of the driver installed.

I also had try to do the command "echo $ > /sys/kernel/debug/vgaswitcheroo/switch" beeing $ = DIS, DDIS, ON, OFF, 0 and 1. The better tries do freeze the machine, the others not even notice the commands and do not change anything. Do change the adapter into amdcccle and reboot into radeon do not worked as well.

The Radeon drives works so nice and it is foss!! I will really appreciate to return using that.

I'm sorry for my bad english language and thank you in advance.


Upcoming Training