Welcome to the Linux Foundation Forum!

Turning Off the Graphical Desktop - problems with systemctl cmd

Options

Hello,

I have a VM ubuntu set up on a macbook via Parallels.

When using the command:
$sudo systemctl stop gdm

The VM screen goes black (after requesting for my password), and there is no way I can type any other command. Kindly see screenshot attached.

On the other hand, if I type the command:
$sudo telenit 3

Graphical Desktop is turned off as expected, and I am allowed to type in new commands again.

When I try to launch again the Graphical Desktop, it works by typing either command
$sudo systemctl start gdm
$sudo telenit 3

I would appreciate if someone could shed some light on what I am doing wrong with the command:
$sudo systemctl stop gdm

Thank you,

Josep Maria

Answers

  • KevinCSmallwood
    Options

    I kind of alluded to this in my answer to your other question regarding using Parallels on MacOS. The Linux Foundation supports Linux. We can help you with Linux. I don't know the specifics of MacOS or the Parallels hypervisor. You would need to consult the documentation for Parallels. Perhaps other students are also using Parallels and could offer some help. Other alternatives include using the free Oracle VM VirtualBox hypervisor which works on Windows, MacOS and Linux. I'm not an expert in VirtualBox, but I don't believe it has the same problems you are experiencing with Parallels.

  • josepmaria
    josepmaria Posts: 13
    Options

    Thanks @KevinCSmallwood , I appreciate your time and answer.

Categories

Upcoming Training