Welcome to the Linux Foundation Forum!

Ch.2 Startup and Shutdown Lab


Hi, When I enter "shutdown now" for the lab exercise in Ch. 2 it shuts the VM of Centos 7 down completely. I have also tried this on a Fedora 22 box. The lab says that "shutdown now" should bring the Linux instance to single user mode- but all of my attempts shut it down completely. Any ideas?



  • coop
    coop Posts: 915
    I did some investigation. The man page for shutdown says the default behaviour is to shut off the machine, not go to single user mode. ("-P, --poweroff Power-off the machine (the default)") I tested on Fedora 21, RHEL7, openSUSE and this is indeed what happens. on Ubuntu 14.04 it does go to single user mode, so it appears to me that they are non-compliant with the man page. As far as RHEL6 goes, I did not check, but I suspect that is also non-compliant as the original discussion was probably written before RHEL7 was common.

    We will reword the discussion appropriately for the next online minor update (in a few weeks at most)


    (By the way, if you are running FC-22, you are either very brave to be running the beta release which came out two days ago, or you have a time machine)

  • adamherst
    adamherst Posts: 25
    It looks like there are different behaviours documented for shutdown depending on the distro. The Ubuntu man page says:
    If no option is specified, the default action is to bring the system down into single-user mode.

    When I try "sudo shutdown now" on Ubuntu (both real and virtual machines) it hangs with a blank screen and only responds to ctrl-alt-delete. Doing "sudo telinit 1" results in the same behaviour.

    On investigation, it sounds like this bug has been around for a while:



  • laacid
    laacid Posts: 3
    Thanks Jerry (and Adam). I tried it on the Centos 6 VM downloaded from training.liniuxfoundation.org vm repo and it does bring it to single user mode with "shutdown now".

    I did download the FC-22 on Tue as soon as it came up. Put it on a tertiary box for alpha and beta testing. Just for fun.

    Thanks again



Upcoming Training