Welcome to the Linux Foundation Forum!

Please help - Lab 7A issue

Options

I was having issues with lab 8 and could not move forward, so I started all over again.

Now I am having an issue in Lab 7A

flux bootstrap github --owner=$GITHUB_USER --repository=flux-infra --branch=main --path="./clusters/staging" --personal --log-level=debug --network-policy=false
► connecting to github.com
► cloning branch "main" from Git repository "https://github.com/guyenko/flux-infra.git"
✔ cloned repository
► generating component manifests
✔ generated component manifests
✔ component manifests are up to date
✔ reconciled components
► determining if source secret "flux-system/flux-system" exists
✔ source secret up to date
sync path configuration ("./clusters/staging") would overwrite path ("./cluster/dev") of existing Kustomization

Why do I get this error?

Best Answer

  • luisviveropena
    luisviveropena Posts: 1,163
    Answer ✓
    Options

    Hi @idelossantos4,

    Have you bootstrapped the same source before in the same system? I haven't seen this issue before, but it looks like flux already have done this, and now it's complaining about overwriting the local files.

    I found an issue that looks pretty similar:

    https://github.com/fluxcd/flux2/discussions/1517

    So, you can delete the local directory, do a 'flux uninstall' and try again.

    I hope that helps.
    Luis.

Answers

  • idelossantos4
    idelossantos4 Posts: 12
    Options

    I ran flux uninstall --namespace=flux-system I was able to proceed bootstrapping flux for the staging cluster

  • luisviveropena
    luisviveropena Posts: 1,163
    Options

    Hi @idelossantos4, thanks for confirming the solution! I'm glad it worked :)

    Regards,
    Luis.

Categories

Upcoming Training