Welcome to the Linux Foundation Forum!

A NordVPN update caused NordVpn to stop working on the Command line


I am brand new here and I should mention that I have very limited networking knowledge. Sorry for the length but I wanted give as much detail as possible but I tried to keep it organized

Description of the problem:
1. I use MX linux version 21. I received an automatic update on January 16th from MX Linux for NordVPN after which I could no longer access a NordVPN server using the command line. MX Linux does not use SytemD. I don't know if that matters. I could not get a straight answer from Zendesk.
2. I could access a Nord server by manually using openvpn and a configuration file supplied by Nord. (they provided configuration files for all their servers)
3. Once I was connected to Nord using openvpn I could then use the command line to access another Nord server. Nord uses Nordlynx which is a clone of Wiregaurd on the command line.
4. if, after connecting to Nord using nordlynx on the command line, I then uncheck the openvpn connection, the nordlynx connection also stops.
5. While connected to Nord using nordlynx (while also connected using openvpn in network manager) I cannot access my private network nor my router but there is no reduction in internet traffic. So while I cannot ping my router or access it using its address, Internet traffic is unaffected.
6. If I turn off the router firewall then I can access Nord servers using the command line without first using openvpn in Network Manager without problem BUT then I can no longer access my private network including my router.

SO its quite complicated. Also WAY above my knowledge level. I am a scientist who has used computers since you had program them in machine language so I am no novice but I never had to learn much about networking.

What I have done so far:
1. I posted on the MX Linux Forum and the developer told me that no one else was having a problem with the update and that they had no idea what was wrong.
2. I contacted NordVPN even though past issues had to be solved without their help. They use Zendesk services to provide support but none of their employees are actually qualified to be providing support except the most basic Windows support. Anything complicated is beyond their expertise. I gave up after a very frustrating week of talking to people who knew less than I did.
3. I made sure that the ports that Nord claims to use are open in the router firewall. However using netstat and ss I see no evidence that they use those ports but instead use port 83999 which their Zendesk support apparently never heard of. I have not opened that port because Nord seems to get through it just fine.
4. I removed and reinstalled Nordvpn twice. The first time using "purge" and the second time again using "purge" but then also painstakingly going through my system looking for NordVPN droppings. There were a lot.
5. Spent a week reading up on networking protocols and how routers worked but found nothing that looked like it might be causing my conditions.
6. One other thing I tried was to use a Nord command to use openvpn from the command line. That made no difference. Openvpn worked with manual configuration with the network manager but using it on the command line was no different than using Nordlynx.

SO that's it.


Upcoming Training