Welcome to the Linux Foundation Forum!

Pod to pod communication not working with Cilium

smarshie73
smarshie73 Posts: 2
edited February 1 in LFS258 Class Forum

Hi. I installed Cilium as per instructions in Dec 2023 lab exercises (using the supplied manifest cilium-cni.yaml).

I've noticed that after creating the nginx deployment and service in Exercise 3.4 that it can only be reached from the node the pod is running on. If I scale up the deployment then it seems to be hit and miss whether curl succeeds (I assume depending on which endpoint the request is handed off to by the service).

Running cilium connectivity tests as advised on the cilium website (using kubectl apply -n cilium-test -f https://raw.githubusercontent.com/cilium/cilium/1.15.0/examples/kubernetes/connectivity-check/connectivity-check.yaml) confirms the problem, with failure on all tests of the type pod-to-b-multi-node.... or host-to-b-multi-node.

Why would this be happening and what should be done to put it right?

I should point out that my two nodes are both in the same VPC in AWS and both have completely open security groups.

Cheers

Steve

Answers

  • Ahh I worked it out. Turns out that opening up TCP was not enough. Cilium relies on UDP encapsulated packets. Opening up everything on UDP fixed it.

  • chrispokorni
    chrispokorni Posts: 2,117

    Hi @smarshie73,

    The introductory chapter has a demo video on AWS EC2 lab environment, which covers critical details such as SG rules, instance size, and recommended OS.

    Regards,
    -Chris

Categories

Upcoming Training