Welcome to the Linux Foundation Forum!

SSH connection to virtual Google machine fails after reboot

Hi,

after configuring a local repository in lab 3.2 a reboot of the control plane was required. After that, connecting to the machine via SSH was impossible, while the machine seems to operate normally from what I see in the logs.

I used to connect to an ephemeral IP so I changed the setting in Putty, but since switched to a reserved IP4. The firewall must be OK, it worked before the reboot plus the worker machine is accessible. I tried stuff like creating an image and reinstalling the machine but to no avail. Also, the SSH-in-browser cannot connect to port 22, but when I start "Troubleshoot" it reports the VM and networking is OK.

I could just create a new machine and it is more work to fix my problem than to go to the previous lab steps, but I am trying to get to know GCP some more. So I was hoping someone has a good bag of tricks for this.

Thank you for any hint,
Tim

Comments

  • chrispokorni
    chrispokorni Posts: 2,117

    Hi @timvdh,

    Have you tried another reboot from the GCE console? Can you connect from the in-browser terminal at all, by clicking the SSH symbol?

    Regards,
    -Chris

  • timvdh
    timvdh Posts: 2

    Thanks, I didn't get your message before logging in again... changed my notification settings now.

    I had tried to reboot several times. Not sure about the console, I think I tried that but I am not sure if it worked. I have now recreated the machine - backed up before the the reboot step - but this time it worked.

Categories

Upcoming Training