Lab-7.1: Failed to fetch url
this is my solution for lab-7.1
and i start the application using this script
"dev": "BOAT_SERVICE_PORT=3333 BRAND_SERVICE_PORT=3334 fastify start -w -l info -P app.js"
'use strict'
const {
BOAT_SERVICE_PORT,
BRAND_SERVICE_PORT
} = process.env
const schema = {
params: {
type: 'object',
additionalProperties: false,
properties: {
id: { type: 'integer' }
}
}
}
const boatUrl = `http://localhost:${BOAT_SERVICE_PORT}`;
const brandUrl = `http://localhost:${BRAND_SERVICE_PORT}`;
module.exports = async function (fastify, opts) {
fastify.get('/:id', {schema: schema}, async function (request, reply) {
const {id} = request.params;
const boatResponse = await fetch(boatUrl + '/' + id);
if (boatResponse.status === 404) {
console.log('not found')
throw fastify.httpErrors.notFound()
}
const boatResult = await boatResponse.json();
const brandResponse = await fetch(brandUrl + '/' + boatResult.brand);
if (brandResponse.status === 404) {
throw fastify.httpErrors.notFound();
}
const brandResult = await brandResponse.json();
return {
id: id,
color: boatResult.color,
brand: brandResult.name
}
})
}
but i got this error
ERROR (1934): fetch failed
reqId: "req-1"
req: {
"method": "GET",
"url": "/1",
"hostname": "localhost:3000",
"remoteAddress": "::1",
"remotePort": 52469
}
res: {
"statusCode": 500
}
err: {
"type": "TypeError",
"message": "fetch failed: connect ECONNREFUSED ::1:3333",
"stack":
TypeError: fetch failed
at Object.fetch (node:internal/deps/undici/undici:11576:11)
at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
at async Object.<anonymous> (/Users/ibrahim/node-training/lab-7.1/routes/root.js:21:26)
caused by: Error: connect ECONNREFUSED ::1:3333
at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1495:16)
any thoughts ?
Comments
-
Your Error status code response is
500, which forHTTPstatus codes is an Internal Server Error. Are you certain that local server is up & running and that it is set up to receive this routedGETrequest? Also, you got this fetch from whicheverlocalhostyou have set up on Port 3000 — is that theBOAT_SERVICE_PORTlocalshostserver or theBRAND_SERVICE_PORTlocalhostserver? I'd look at whichever one of those is onlocalhost:3000and start there.0 -
if you have connection refused it means you're not running the necessary services on those ports
0
Categories
- All Categories
- 178 LFX Mentorship
- 178 LFX Mentorship: Linux Kernel
- 775 Linux Foundation IT Professional Programs
- 384 Cloud Engineer IT Professional Program
- 175 Advanced Cloud Engineer IT Professional Program
- 75 DevOps IT Professional Program - Discontinued
- 7 DevOps & GitOps IT Professional Program
- 103 Cloud Native Developer IT Professional Program
- 7.7K Training Courses & Learning Paths
- 13 AI & ML Training
- 1 Blockchain & Decentralized Identity Training
- 35 Cloud & Containers Training
- 3 Cybersecurity Training
- 3 DevOps & Site-Reliability Training
- 2 Linux Kernel Development Training
- 2 Networking Training
- 2 Open Source Best Practice Training
- 5 System Administration Training
- 1 System Engineering Training
- 6 Web & Application Development Training
- 798 Hardware
- 202 Drivers
- 68 I/O Devices
- 37 Monitors
- 96 Multimedia
- 173 Networking
- 91 Printers & Scanners
- 92 Storage
- 773 Linux Distributions
- 81 Debian
- 68 Fedora
- 24 Linux Mint
- 13 Mageia
- 24 openSUSE
- 151 Red Hat Enterprise
- 32 Slackware
- 13 SUSE Enterprise
- 356 Ubuntu
- 472 Linux System Administration
- 31 Cloud Computing
- 73 Command Line/Scripting
- Github systems admin projects
- 103 Linux Security
- 79 Network Management
- 102 System Management
- 46 Web Management
- 166 Mobile Computing
- 32 Android
- 119 Development
- 1.2K New to Linux
- 1K Getting Started with Linux
- 407 Off Topic
- 128 Introductions
- 35 Study Material
- 1.1K Programming and Development
- 311 Kernel Development
- 723 Software Development
- 1K Software
- 418 Applications
- 183 Command Line
- 5 Compiling/Installing
- 71 Games
- 320 Installation
- Archived
- 183 Small Talk
- 2 LFD140 Class Forum
- 1.4K LFS258 Class Forum
Upcoming Training
-
August 20, 2018
Kubernetes Administration (LFS458)
-
August 20, 2018
Linux System Administration (LFS301)
-
August 27, 2018
Open Source Virtualization (LFS462)
-
August 27, 2018
Linux Kernel Debugging and Security (LFD440)

