Welcome to the Linux Foundation Forum!

Lab 4 docker compose error getting credentials

oskarq
oskarq Posts: 22
edited December 2023 in LFS261 Class Forum

I ran sudo docker compose build and It doesn't work.
I am using MacOS M1.

output:
[+] Building 0.5s (2/3) docker:desktop-linux
[+] Building 0.6s (3/3) FINISHED docker:desktop-linux
=> [jenkins internal] load .dockerignore 0.0s
=> => transferring context: 2B 0.0s
=> [jenkins internal] load build definition from Dockerfile 0.0s
=> => transferring dockerfile: 982B 0.0s
=> ERROR [jenkins internal] load metadata for docker.io/jenkins/jenkins:2.375-jdk11 0.6s

[jenkins internal] load metadata for docker.io/jenkins/jenkins:2.375-jdk11:

failed to solve: jenkins/jenkins:2.375-jdk11: error getting credentials - err: exit status 1, out: ``

Answers

  • oskarq
    oskarq Posts: 22

    Solved by changing to the latest version of Jenkins

  • luisviveropena
    luisviveropena Posts: 1,129

    Hi @oskarq,

    That was a good idea. There are also some code that will work with a specific combination of versions. It happens and it's a kind of complicate thing, because it's not just "let's update everything" and expect it to work in every case.

    Many regards,
    Luis.

Categories

Upcoming Training