Welcome to the Linux Foundation Forum!

Nano setup

Options

Hi.

While practicing I had my nano setup with nano -cliET4. Pasting from the outside worked and the Alt key worked as command (like, Alt+A to set mark, etc)

Now I did my first of the training session in the environment, and have some problems:

  • I could not find out which key is mapped on cmd, it was not Alt and not Escape, which could it be?
  • Pasting from the inbuilt firefox shifts around all indentations

Could you please give me any hints on this?

Answers

  • chrispokorni
    Options

    Hi @ebiz.silvie2023,

    The indentation does become an issue when pasting from any browser or from the lab guide PDF. Fixing the indentation on a few lines is part of the learning experience. However, keep in mind that the SOLUTIONS tarball incorporates all the necessary manifests and shell scripts that are required for labs, most needing minor to no edits at all before using.

    As far as key mapping I'd recommend exploring the official nano docs or the various guides sharing tips and tricks to manage nano configuration and nanorc.

    Most Kubernetes resources present definition manifests in yaml with indents of 2 rather than 3 or 4, while tab uses spaces.

    Editing live Kubernetes resources defaults to vim, but can be reconfigured to nano by setting the KUBE_EDITOR environment variable to the path to nano (or other editor of choice).

    Regards,
    -Chris

  • ebiz.silvie2023
    Options

    Hi Chris,

    I was talking about the killer.sh sessions. There’s a solutions tarball? I know that solutions page, but yeah copying😅

    I just felt like I spent a lot of time fixing indentation after copying from kubernetes.io and I could definitely need that time in the exam, as it took me full 3hrs to finish those 22 tasks of the killer.sh session. So I thought it would be helpful if I could find a way to do it correctly to save me that time in the exam.


    I found out what the problem was about the Alt key: The terminal on that remote desktop machine has a setting turned on that overwrites many Alt+[key] combinations. It is a checkmark under Preferences in the terminal window that can be turned off. Leaving this here incase others might have that issue as well, definitely a problem if you stumble across that in the short time of the exam. I hope that setting is in the same place in the exam as well.

    I don’t really understand what you’re saying about tabs and space or how it relates to my question?

    I know about the KUBE_EDITOR setting, thanks :) I always set it first thing using:

    export KUBE_EDITOR=“nano -cliET4”

  • chrispokorni
    Options

    Hi @ebiz.silvie2023,

    That relevant piece of info "killer.sh" would have helped me to provide you with a better answer... What seems not to relate to your question, it was meant for a different question altogether :wink:

    Keep in mind that on the actual exam, the typical copy, paste, and other popular keyboard shortcuts will be different.
    Good luck preparing for and on your certification exam!

    Regards,
    -Chris

  • ebiz.silvie2023
    Options

    Oh, sorry, I should have been more specific.

    Are you saying that shortcuts can be different in the exam environment than from killer.sh?

    I can cope with copy paste not working and use mouse rightclick menu, but if it disables the Alt key for nano in an even different way that I can’t find how to fix, then it would be a real problem as marking and copypaste within the editor relies on it.

  • chrispokorni
    Options

    Hi @ebiz.silvie2023,

    Yes, shortcuts will behave differently. Please read carefully the "Candidate Handbook", "Exam Tips", and "FAQ" from the certification info page to familiarize yourself with the exam environment, that will include the supported keyboard shortcuts.

    Regards,
    -Chris

  • ebiz.silvie2023
    Options

    I have read through everything, I found for example that copypaste can be Ctrl+Shift+C (https://docs.linuxfoundation.org/tc-docs/certification/lf-handbook2/exam-user-interface/examui-performance-based-exams)

    but it is nowhere written whether the Alt combinations in nano will work.


    And elsewhere on the internet I am only finding information about the old exam UI.

  • fcioanca
    fcioanca Posts: 1,964
    Options

    Hi @ebiz.silvie2023

    If the documentation did not provide the answer you were looking for, please open a ticket with the Linux Foundation Customer Support team at trainingsupport.linuxfoundation.org and they can answer any exam-related questions. Please note that response time can take several business days (no weekends or holidays).

    Regards,

    Flavia

    The Linux Foundation Training Team

  • ebiz.silvie2023
    Options

    Thanks, I did that.

    I was planning to test this week, but probably have to shift that then until I get an answer from there.

  • ebiz.silvie2023
    ebiz.silvie2023 Posts: 6
    edited December 2023
    Options

    Got an answer from the support and wanted to share the info incase it helps anyone in the future.
    The Terminal used in the exam is the "xfce4-terminal".
    The setting to disable all menu access keys is at the same place as in the killer.sh environment (Preferences, Advanced, tick the first checkbox in the list, it says something about Alt keys)
    All the key combos that I tried (mark, search, etc) work then.

    You can also download an xfce4-terminal on any of your own linux device and see the setting beforehand.
    Additionally, if you were to not find the setting, the Alt key combos still work when used with Shift, so Shift+Alt+A.
    And alternatively ofc you could start nano with mouse mode (-m) and use the mouse to mark. Personally I didnt like that but ymmv.

Categories

Upcoming Training