Welcome to the Linux Foundation Forum!

lab 4.1. Problem while running command peer channel list

Hello everyone, while accessing the lab 4.1, error happens while running command "peer channel list",

**2023-11-21 15:21:40.828 +0545 [channelCmd] InitCmdFactory -> INFO 001 Endorser and orderer connections initialized
Error: Failed sending proposal, got rpc error: code = Unknown desc = error validating proposal: access denied: channel [] creator org unknown, creator is malformed
**

i tried to resolve but the same error keep happened, is there anyone who can guide me on this? thanks in advance...!

Answers

  • Bobbijn
    Bobbijn Posts: 186

    Hello,

    Thank you for reaching out with your issue in lab 4.1 of the LFD272 course. The error message you're encountering typically indicates an issue with the identity of the user trying to execute the command.

    Here are a few steps you can take to troubleshoot and resolve this problem:

    Check Your Environment Settings: Ensure that your environment variables are correctly set. The identity that you are using to execute the peer channel list command should have the necessary permissions on the channel you're trying to access. Verify that the CORE_PEER_MSPCONFIGPATH is pointing to the correct MSP (Membership Service Provider) directory of the user.

    Examine the MSP Configuration: The error suggests that there might be a problem with the MSP configuration of the user. Double-check the MSP setup in your network configuration to ensure that it properly recognizes the organization and the user.

    I hope these suggestions help you resolve the issue. Let me know how it turns out. Bobbi

  • Thanks for the suggestions.

Categories

Upcoming Training