Welcome to the Linux Foundation Forum!

LAB 3.2 / 3.3 worker node joins cluster but is stuck in NotReady state

I've followed all of lab 3.1 and 3.2, but when beginning 3.3 and running the kubectl get node command, my worker is stuck in a NotReady state
When I run kubectl describe node I get a Ready False condition with the following reason:
container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:Network plugin returns error: cni plugin not initialized

running kubectl get pods -n kube-system shows two pods that are not ready:
cilium-operator-blahblahblah 0/1 Running 12 restarts
cilum-blahblahblah 0/1 Init:CrashLoopBackOff

Trying to diagnose those using google is proving to be a little over my head at this stage.

I am going through the labs on VirtualBox VMs running Ubuntu 20.04 server edition, my host is Ubuntu 22.04 desktop edition

Comments

  • chrispokorni
    chrispokorni Posts: 2,025

    Hi @paulkx,

    What is the size of the vbox VM (cpu, mem, disk)? What type of network interface is configured for the VM? Is promiscuous mode enabled to allow all traffic to the VM?

    Regards,
    -Chris

  • paulkx
    paulkx Posts: 4

    Hi @chrispokorni,
    The VMs are both 2 cpus, 8GB ram and 25GB of disk space.
    I think the network interfaces might be the issue - they both have a default NAT interface and a manually configured Host-only VirtualBox network (No DHCP, statically assigned IPs for both)
    I have set the controlplane to use it's static IP from the latter interface as it's controlPlaneEndpoint, and have set the podSubnetwork to be the ip-range of this interface in kubeadm init config file.
    I suspect the problem is here somewhere but I don't know enough to know what could be going wrong.

    I don't know about promiscuous mode but I'll be googling that as soon as I've posted this

  • paulkx
    paulkx Posts: 4

    Promiscuous mode was set to deny, but is now enabled but no change to the error

  • chrispokorni
    chrispokorni Posts: 2,025

    Hi @paulkx,

    Try with a single bridged adapter per VM (it is a configuration that consistently worked for me, while there may be other solutions as well). Static IP or DHCP should be ok.
    On the network adapter tab, simply check promiscuous mode and select "allow all" from the drop down menu.

    Regards,
    -Chris

  • paulkx
    paulkx Posts: 4

    That seems to have fixed it, thanks very much @chrispokorni

Categories

Upcoming Training