Welcome to the Linux Foundation Forum!

Lab 5.3 - Fluentd container image issues


While doing lab 5.3 I had some issues with step 14: my yaml file was correct but looking at the logs from "fdlogger" it looked as if the configmap was not being read and as such in step 17 I could not see the logs like in the picture.

After some digging I found out that the current image of fluentd used in the lab does not expose an environment variable called FLUENTD_OPT. I tried FLUENT_CONF but had some issues with the path.

Changing the pod container image to "bitnami/fluentd" (where I saw that the variable FLUENTD_OPT was exposed) made it so I could complete the lab.

Hoping this can help others and also help keeping the training labs up to date.


  • aurelil

    I also had problems finishing Lab 5.3. because I couldn't see the logs. The latest version that allowed me to complete this task bitnami/fluentd:1.16.2 no longer works on more recent releases. 30.10.23

  • jsamaroo
    jsamaroo Posts: 1
    edited November 2023

    Also had this issue. This was my resolution...

    This type of notation worked for me. The entrypoint.sh actually loads -c "path to config" after an "$@" so it will override whatever we had. See note at end.

    Also take note of no spacing between the 'c' and the argument for config, as this method will prefix a ' ' to the arg and give an ENOENT filenotfound error.

    - name: FLUENTD_OPT
      value: -c/etc/fluentd-config/fluentd.conf
    command: ["/bin/entrypoint.sh"]
    args: ["$(FLUENTD_OPT)"]

    Hope this will clear up the bugs. (I'm using arm64 since I'md doing the work using a Mac arm processor on UTM (qemu) under the hood.) It appears to be the same for others as well though.

    Source for entrypoint.sh bug:

  • ignace.hakizimana

    I had the same issue and this helped me

  • klarabauyrzhanova

    Thanks, @jsamaroo
    It was very helpful <3

  • juetten
    juetten Posts: 3

    Thx ... actually a google search while solving the exact same issue took me here :smile:

  • samson2ky

    I used this:

      - name: fdlogger
        image: fluentd
        command: ["/bin/entrypoint.sh"]
        args: ["-c", "/etc/fluentd-config/fluent.conf"]


Upcoming Training