Welcome to the Linux Foundation Forum!

CKA Strange “:” character issue

Options
boerme
boerme Posts: 1
edited October 2023 in LFS258 Class Forum

Just took the CKA exam, and although I knew the answers to all questions, it was all ruined due to the “:” character not getting through.

The nightmare started with me having to drop my 27” monitor due to the web cam not being able to autozoom and take a picture of my drivers license, so stuck with my tiny macbook air m1 13” screen.

So while editing my yaml in vim, I was not able to exit the editor due to the “:” not getting through. So I open a new terminal and copied the vim content. This happened about 5 or 6 times and a lot of time was wasted there.

Especially one time I had to append something to an existing pod without changing the existing settings, so I yaml’ed it to a file. Deleted the pod and made the changes to the yaml, and got stuck again. I couldn’t just start over in the new terminal since the pod was gone, and I couldn’t just copy the file, because the changes were only in the stuck editor. After finally having copy/pasted all (had to do it a few lines at a time due to the tiny monitor), the damn yaml didn’t work and I had to waste time investigating, until I realized that my changes lacked “:” as well ☹ This simple question alone cost me about 20 minutes.

Next problem was that it was turning dark very quickly, and I had to move away from the screen to switch the lights on. It was just 1½ meters away, but I’m in a wheelchair and had to roll over there instead of just leaning over. The protector then paused my exam for about 3 min. before returning and chatting with me, giving me a warning. All this was an extra 5 min waste.

Finally an etcd backup wouldn’t work (I doublechecked that I was in the right context and the right node). I have done dozens of etcd backup/restores in preparation and don’t find it too difficult.
Both endpoint and cert/keys were given. So I ssh’ed into master node and did the backup, only to be met with an “…/peer.crt” permission denied. Also tried it with the usual server.crt, but then just got a “…/server.crt” permission denied.

There was no mention of investigating backup trouble, so I think there was something wrong with the environment…maybe a etcdctl etcd pod version mismatch?
Anyway, I didn’t have time to investigate, so had to skip what seemed like a simple question ☹.
So in the end only managed 11 questions out of 17, so I don’t expect to pass.

Created a ticket and hoping to get a new first try.

Ordered a better web cam with autozoom, so hopefully I will be able to use my 27” monitor next time. Oh, and I tested the “:” key after the exam and it worked perfectly fine.

Comments

  • fcioanca
    fcioanca Posts: 1,904
    Options

    Hi @boerme

    We are sorry to hear about your experience. If you already opened a ticket at trainingsupport.linuxfoundation.org, the Linux Foundation Customer Support team (not PSI) will be assisting you in rescheduling your exam at a later time.

    Regards,
    Flavia
    The Linux Foundation Training Team

Categories

Upcoming Training