Welcome to the Linux Foundation Forum!

LFS258: new version available (9.5.2023)



A new course version of LFS258 went live on 9.5.2023. This course has been updated to v1.28.1.

To ensure you have access to the latest updates, please clear your cache. We hope you will have a great learning experience and enjoy the updated LFS258.


Kassidy Barratt

The Linux Foundation Training Team


  • bbland

    so im trying to finish a lab i started a few months ago i see that there was an update to the course but i am running into this issue when trying to do Lab 4

    ubuntu@ip-172-31-85-189:~$ sudo apt-get update && sudo apt-get install -y kubelet=1.28.2-00 kubectl=1.28.2-00
    Hit:1 http://us-east-1.ec2.archive.ubuntu.com/ubuntu focal InRelease
    Hit:2 http://us-east-1.ec2.archive.ubuntu.com/ubuntu focal-updates InRelease                    
    Hit:3 http://us-east-1.ec2.archive.ubuntu.com/ubuntu focal-backports InRelease                  
    Hit:4 http://security.ubuntu.com/ubuntu focal-security InRelease                                
    Hit:6 https://download.docker.com/linux/ubuntu focal InRelease                                  
    Hit:5 https://packages.cloud.google.com/apt kubernetes-xenial InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    kubectl is already the newest version (1.28.2-00).
    kubelet is already the newest version (1.28.2-00).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    ubuntu@ip-172-31-85-189:~$ sudo kubeadm upgrade plan
    [upgrade/config] Making sure the configuration is correct:
    [upgrade/config] Reading configuration from the cluster...
    [upgrade/config] FYI: You can look at this config file with 'kubectl -n kube-system get cm kubeadm-config -o yaml'
    [upgrade/config] FATAL: this version of kubeadm only supports deploying clusters with the control plane version >= 1.27.0. Current version: v1.26.1
    To see the stack trace of this error execute with --v=5 or higher

    I dont understand what i need to update to get the upgrade plan command to work please advise

  • chrispokorni

    Hi @bbland,

    Kubernetes supports upgrades between consecutive versions, such as 1.26 to 1.27, and 1.27 to 1.28.




Upcoming Training