Welcome to the Linux Foundation Forum!

Lab 11.2 Node IP does not work with ingress

Options

I can not reach the service using the node IPs via ingress by following the Lab guide.

Lab 11.2, Step 15. mentions:

Test the second Host: setting using curl locally as well as from a remote system, [...]
Use the main IP of either node.
student@cp: ̃$ curl -H "Host: internal.org" http://10.128.0.7/

I've followed all the steps in the Lab very carefully, but there's no process litening on port 80 on any of the nodes. (Checked with netstat -lntp).

I've managed to find a solution by setting the following option of ingress-nginx in values.yaml before installing it:

hostPort:
    enabled: true

This is set to false by default.
This step is not mentioned in the Lab document.

Am I missing something or should the above option be mentioned in the guide?

(Lab guide verion: V 2023-06-22, chart: ingress-nginx-4.7.1)

Comments

  • chrispokorni
    chrispokorni Posts: 2,192
    Options

    Hi @kelemensanyi,

    Enabling the hostPort in values.yaml is one approach. You can also edit the myingress-ingress-nginx-controller DamonSet once it is created and add the desired hostPorts.

    Regards,
    -Chris

Categories

Upcoming Training