Welcome to the Linux Foundation Forum!

Lab 4 - connection error to redis


vote app is unable to connect to redis in chapter "Feature-InternalServiceDiscovery" in the Lab 4 PDF.

ConnectionError: Error -3 connecting to redis:6379. Try again.

kubectl exec -ti redis-647d66978-r9c7t sh:

[2023-08-03 15:08:16,321] ERROR in app: Exception on / [POST]
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/flask/app.py", line 1982, in wsgi_app
    response = self.full_dispatch_request()
  File "/usr/local/lib/python2.7/site-packages/flask/app.py", line 1614, in full_dispatch_request
    rv = self.handle_user_exception(e)
  File "/usr/local/lib/python2.7/site-packages/flask/app.py", line 1517, in handle_user_exception
    reraise(exc_type, exc_value, tb)
  File "/usr/local/lib/python2.7/site-packages/flask/app.py", line 1612, in full_dispatch_request
    rv = self.dispatch_request()
  File "/usr/local/lib/python2.7/site-packages/flask/app.py", line 1598, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File "/app/app.py", line 32, in hello
    data = json.dumps({'voter_id': voter_id, 'vote': vote})
  File "/usr/local/lib/python2.7/site-packages/redis/client.py", line 1282, in rpush
    return self.execute_command('RPUSH', name, *values)
  File "/usr/local/lib/python2.7/site-packages/redis/client.py", line 578, in execute_command
  File "/usr/local/lib/python2.7/site-packages/redis/connection.py", line 563, in send_command
  File "/usr/local/lib/python2.7/site-packages/redis/connection.py", line 538, in send_packed_command
  File "/usr/local/lib/python2.7/site-packages/redis/connection.py", line 442, in connect
    raise ConnectionError(self._error_message(e))
ConnectionError: Error -3 connecting to redis:6379. Try again.

Tried both with schoolofdevops/vote:v5 and schoolofdevops/vote:latest.


  • luisviveropena

    Hi @dietrich.vatter,

    I went through all Lab 4 and it worked for me. I used Ubuntu LTS 22.04 and 16 GB of memory, 40 GB of storage on GCP.

    So, as I wasn't unable to reproduce the issue, I recommend the following:

    1.- Delete the deployment.
    2.- Delete the service.
    3.- Create the deplyoment.
    4.- Create the service.
    5.- Try the App again.



Upcoming Training