Welcome to the Linux Foundation Forum!

Lab 2.2 kubeadm join... is stuck

Options
nikolaichuks
nikolaichuks Posts: 2
edited July 2023 in LFD259 Class Forum

Hello
I'm stuck on running scripts for worker node,
I use aws, worker node has:
1 t3.large instance type
2 Ubuntu image ubuntu/images/hvm-ssd/ubuntu-jammy-22.04-amd64-server-20230516
3 20 GB memory

I don't get errors during running of script bash k8sWorker.sh, but it stucks after running sudo kubeadm join... command
also I can't get info about nodes in k8s, I get error:
E0709 16:25:27.916554 18505 memcache.go:265] couldn't get current server API group list: Get "http://localhost:8080/api?timeout=32s": dial tcp 127.0.0.1:8080: connect: connection refused The connection to the server localhost:8080 was refused - did you specify the right host or port?

and I don't see any errors during running setup-script( logs attached)

When I run sudo kubeadm join... from cp it stucks.
When I run sudo kubeadm join... with -v2 flag(after some googling) it logs:
"I0709 16:32:25.446263 18797 checks.go:329] validating the contents of file /pr oc/sys/net/bridge/bridge-nf-call-iptables
I0709 16:32:25.446372 18797 checks.go:329] validating the contents of file /pr oc/sys/net/ipv4/ip_forward
I0709 16:32:25.446409 18797 join.go:529] [preflight] Discovering cluster-info
I0709 16:32:25.446443 18797 token.go:80] [discovery] Created cluster-info disc overy client, requesting info from "172.31.42.234:6443"
I0709 16:32:35.450442 18797 token.go:217] [discovery] Failed to request cluster-info, will try again: Get "https://172.31.42.234:6443/api/v1/namespaces/kube-public/configmaps/cluster-info?timeout=10s": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)"

Could you help me? I have no idea how to solve this issue

Comments

  • nikolaichuks
    Options

    it was resolver by using older version of Ubuntu + usage of security groups to allow ALL traffic
    can be closed

  • chunkuoli
    Options

    The connection timeout issue can be solved by this 2 steps.

    (1) In the security group that is shared between the 2 EC2s of CP and Worker, make sure it has this 3 inbound rules:

    (2) Once the 2 nodes are up running, at the paragraph 8 of lab exercise 2.2, add the following line to .bashrc:
    "export KUBECONFIG=/etc/kubernetes/kubelet.conf"
    and then ". .bashrc"

    After those 2 steps, the paragraph 8 should be ran through successfully.

    There could be also some file permission issues. However, it is obviously to solve it by "sudo chmod +rwx [filename]"

    Hope this helps.

Categories

Upcoming Training