Welcome to the Linux Foundation Forum!

LFD259 Exercise 7.2, Step 15: ingress-controller pods not being created

andrew.nichols Posts: 6
edited June 2023 in LFD259 Class Forum

Hello everybody,

I'm running into issues on LFD259 Exercise 7.2, 'Service Mesh and Ingress Controller,' Step 15. The command helm install myingress . went as expected, installing myingress in the default namespace (the output clearly says so). The service 'secondapp' is configured as a LoadBalancer on 80:32000/TCP, as outlined in the lab.

Here is what I am seeing:

myhostname@cp:~/app2/ingress-nginx$ helm install myingress .
NAME: myingress
LAST DEPLOYED: Thu Jun  8 21:46:28 2023
NAMESPACE: default
STATUS: deployed
The ingress-nginx controller has been installed.

myhostname@cp:~$ kubectl get ingress --all-namespaces
No resources found
myhostname@cp:~$ kubectl --namespace default get services -o wide myingress-ingress-nginx-controller
NAME                                 TYPE           CLUSTER-IP    EXTERNAL-IP   PORT(S)                      AGE   SELECTOR
myingress-ingress-nginx-controller   LoadBalancer   <pending>     80:30795/TCP,443:31467/TCP   17m   app.kubernetes.io/component=controller,app.kubernetes.io/instance=myingress,app.kubernetes.io/name=ingress-nginx
myhostname@cp:~$ kubectl get pod --all-namespaces | grep nginx
default       nginx-79ff9c85db-pcf9v                     1/1     Running   0               2d4h

As you can see, the two 'myingress-ingress-nginx-controller-xxxxx' pods do not exist.

What is the issue likely to be, and how can I fix it?

I am using one cp node and one worker node on GCE using the standard lab setup described in the videos: Ubuntu 20.04.6 LTS (on x86_64 machines), kubectl/kubeadm v1.27.1, and Linkerd 2.12.2. I'm following lab manual V2023-05-31. I think the only deviation I made from the instructions was at step 1 of Exercise 7.2, in which I exported a PATH using my actual hostname instead of 'student' because it looked like there was a typo in the lab. I used this:

export PATH=$PATH:/home/<hostname>/.linkerd2/bin

Linkerd appears to be running fine, as I can see the dashboard and all the appropriate links.

I have tried uninstalling and reinstalling the helm chart, but that did not fix the problem.



  • andrew.nichols
    andrew.nichols Posts: 6
    edited June 2023

    I have figured-out what caused this behavior: when editing the 'values.yaml' file in step 13, I entered 'Daemonset' instead of 'DaemonSet'. After correcting this and reinstalling 'myingress' using helm, the two missing 'myingress-ingress-nginx-controller-xxxxx' pods appeared. Problem solved.


Upcoming Training