Welcome to the Linux Foundation Forum!

Install docker compose with command from labs Picture with error

Options

Installing on another windows 11 machice
First, we need to pull docker-compose using cURL:
sudo curl -L
https://github.com/docker/compose/releases/download/1.27.4/docker-comp
ose-uname -s-uname -m -o /usr/local/bin/docker-compose
We need to change the permissions for docker-compose so we can execute it later:
sudo chmod +x /usr/local/bin/docker-compose

when I run chmod command error says directory /usr/local/bin/docker-compose does not exist.

Any help would be appreciated. Thanks Randy

Comments

  • Bobbijn
    Bobbijn Posts: 190
    Options

    Hi randymor,

    From the error message you've posted, it seems either the docker-compose file did not download correctly or the directory /usr/local/bin does not exist.

    Check if the directory exists: You can use the command ls /usr/local/bin to list all files in this directory. If the directory does not exist, you can create it using sudo mkdir -p /usr/local/bin.

    Re-download docker-compose: If the directory exists, it's possible that the file did not download correctly. You can try to download it again using the same command. As a like before make sure you have the necessary SUDO permissions to download files into this directory.

    Once you have successfully downloaded the docker-compose file, you should be able to make it executable using the chmod command. Let me know how it goes. Bobbi

  • randymor
    randymor Posts: 34
    Options

    Hi Bobbi, Thanks again. I have another error.
    curl -sSL https://bit.ly/2ysbOFE | bash -s -- 2.2.1 1.4.9

    version 2.2.1.1.4.9 does not exist. Am I losing my mind?
    I took this class thinking this would be simple way to create a sample for them.

    Can I ask does Hyperledger offers a cloud version of this I can use to make a simple Fabric example of a farmer delivering the product to a distributor? Want 2 permission entities just the farmer and distributor.
    I'm doing a volunteer project for NGO to just show them the possibilities of using a Hyperledger fabric chain that the data is immutable

  • randymor
    randymor Posts: 34
    Options

  • fcioanca
    fcioanca Posts: 1,904
    Options

    Hi,

    From your screenshot, you do have an extra . in your command, that is not in the lab pdf; version 2.2.1.1.4.9. Should be version 2.2.1 1.4.9. Correct command is:

    curl -sSL https://bit.ly/2ysbOFE | bash -s -- 2.2.1 1.4.9

    I hope this helps.

  • Bobbijn
    Bobbijn Posts: 190
    Options

    :)

  • randymor
    randymor Posts: 34
    Options

    Thanks!

  • rafaelaquinocunha
    Options

    Hi everyone!
    I tried to run the curl -sSL https://bit.ly/2ysbOFE | bash -s -- 2.2.1 1.4.9 command, but I am getting the following error:

    bash: line 1: syntax error near unexpected token newline' bash: line 1:<!DOCTYPE html>'
    (23) Failed writing body

    I am using the following Ubuntu version:

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 18.04.6 LTS
    Release: 18.04
    Codename: bionic

    Any ideas about what could be happening and how to fix it? I am not being able to download Hyperledger Fabric images.

    Thank you!

  • rafaelaquinocunha
    Options

    Hello everyone!
    I have fixed the problem by updating the curl version in Ubuntu manually.

    Link to a tutorial that helped me to do it:
    https://yannmjl.medium.com/how-to-manually-update-curl-on-ubuntu-server-899476062ad6

  • Bobbijn
    Bobbijn Posts: 190
    Options

    Great Job !

Categories

Upcoming Training