Welcome to the Linux Foundation Forum!

Lab 3.1 requested access to python3:latest is denied

Options

Following lab 3.1, when I get to the command
sudo podman build -t simpleapp .

I get the output:

STEP 1/3: FROM docker.io/library/python3
Trying to pull docker.io/library/python3:latest...
Error: creating build container: initializing source docker://python3:latest: reading manifest latest in docker.io/library/python3: requested access to the resource is denied

I tried logging in using:
sudo podman login

and get back the response:
Authenticating with existing credentials for docker.io
Existing credentials are valid. Already logged in to docker.io

So I'm unsure why this command doesn't work.
I used the --from option to specify
sudo podman build --from=fedora:latest -t simpleapp .
and that worked, but this is a deviation from the course. Will this cause problems down the line, and why would podman not be able to build the image using docker.io?

Comments

  • blaket
    blaket Posts: 10
    Options

    Derp I'm sorry, I just had mistyped the Dockerfile. Instead of
    FROM docker.io/library/python3
    it should have been
    FROM docker.io/library/python:3

  • chrispokorni
    chrispokorni Posts: 2,190
    Options

    Hi @blaket,

    Such typos can easily be avoided in the future simply by using the definition and config files provided in the SOLUTIONS tarball, downloaded and extracted (hopefully) earlier in Chapter 2. The Dockerfile is also part of the tarball.

    Regards,
    -Chris

Categories

Upcoming Training