Welcome to the Linux Foundation Forum!

Exercise 3.4: Pods won't provision on Node with message "connection is unauthorized"

Options

After reading I noticed this only happened on one of my two nodes (CP). So I tried restarting kubelet no luck, then tried deleting the CNI pod (calico) that was on the CP so it would restart, hoping that would do the trick. Which it did. I'm just trying to see what I can do to prevent it since the liveliness :# probe didn't catch the issue.

My environment is on VMs using NAT Network with VirtualBox.

The pod had no ERROR logs before deleting, so I'm just wondering what other troubleshoooting steps there are to take in that situation?

Comments

  • chrispokorni
    chrispokorni Posts: 2,190
    Options

    Hi @farazoman,

    For each VirtualBox VM I'd recommend a single network adapter, bridged, with promiscuous mode enabled to allow all traffic. The VBox DHCP server should not use 192.168.0.0/16 IP addresses for VMs, use a different private network, such as 10.200.0.0/16 instead. Also make sure that VM sizes and OS are as follows: 2 CPU cores per VM, 8 GB memory for cp and 4 to 8 GB memory for worker (as available from host system), 15-20 GB disk space, Ubuntu 20.04 LTS guest OS.

    Regards,
    -Chris

  • farazoman
    farazoman Posts: 6
    Options

    Thanks Chris, I was able to set promiscuous mode but otherwise it seems to have been working fine. If it happens again will post here.

Categories

Upcoming Training