Welcome to the Linux Foundation Forum!

How do I run xfstests, with my custom kernel in qemu?


An easy way to do this would be to install a system in a qemu virtual machine, inside that vm compile the kernel, install the kernel and run xfstests. This is not a good development cycle for me.

I would like to compile the kernel in my machine and then pass the kernel as an argument to qemu and then run the xfstests inside the vm.

So far I have only been able to run my custom kernel in qemu with buildroot. However, If I use buildroot to create the filesystem, since buildroot is so bare bones, I can't compile/use xfstests inside of that vm.

I have also tried to pass my custom kernel as an argument for a vm that already has a system installed (debian), like this:

qemu-system-x86_64 -kernel arch/x86/boot/bzImage \
-boot c -m 2049M -hda xtest.img \
-append "root=/dev/sda2 rw console=ttyS0,115200 acpi=off nokaslr" \
-serial stdio -display none

However, I'm still unable to boot it as the kernel doesn't know how to load the system. I suspect it my have to do with the fact that I didn't provide a initrd file, which buildroot takes care of automatically.

How do people normally deal with this?



Upcoming Training