Welcome to the Linux Foundation Forum!

need some help with Lab 13.3 Configure the Dashboard


andres@kubecp1:~$ kubectl top nodes
kubecp1 147m 7% 2163Mi 27%
worker1 95m 4% 2058Mi 26%

instructions are QUITE messy, especially for someone who is NOT an expert in Linux.. or git or anything..

Search https://artifacthub.io/ for thehelmorganization and thekubernetes-dashboardchart
.2. Fetch the chart and edit thevalues.yamlfile.

ok I search for that

in that article I found

helm repo add kubernetes-dashboard https://kubernetes.github.io/dashboard/

helm install kubernetes-dashboard kubernetes-dashboard/kubernetes-dashboard

run both it seems that the pod was installed

andres@kubecp1:~$ cd
andres@kubecp1:~$ helm repo add kubernetes-dashboard https://kubernetes.github.io/dashboard/
"kubernetes-dashboard" has been added to your repositories
andres@kubecp1:~$ helm install kubernetes-dashboard kubernetes-dashboard/kubernetes-dashboard
NAME: kubernetes-dashboard
LAST DEPLOYED: Tue Mar 28 04:27:39 2023
NAMESPACE: default
STATUS: deployed

*** PLEASE BE PATIENT: kubernetes-dashboard may take a few minutes to install ***

Get the Kubernetes Dashboard URL by running:
export POD_NAME=$(kubectl get pods -n default -l "app.kubernetes.io/name=kubernetes-dashboard,app.kubernetes.io/instance=kubernetes-dashboard" -o jsonpath="{.items[0].metadata.name}")
kubectl -n default port-forward $POD_NAME 8443:8443
andres@kubecp1:~$ kubectl get serviceaccounts
default 0 8d
kubernetes-dashboard 0 33s
myingress-ingress-nginx 0 23h

checked my ip:8443, but it didn't work, of course I haven't modify any value.yaml, becusea there was NONE!

search for values.yaml nothing found back to https://artifacthub.io/ and found the the values.yaml

edit the file and follow the instructions on that website BECAUSE THERE IS NOT A SINGLE STEP ON HOW TO INSTALLED on the training instrucction

helm install kubernetes-dashboard/kubernetes-dashboard --name kubernetes-dashboard -f values.yaml

helm install kubernetes-dashboard/kubernetes-dashboard --name kubernetes-dashboard -f values.yaml
Error: unknown flag: --name

checked with
helm install kubernetes-dashboard/kubernetes-dashboard -name kubernetes-dashboard -f values.yaml
still not working, tried different stuff but the same not working

the solution will be on the Solution.tar file, guess what nothing for lab 13.. awesome..

Search on the forum, there are many many topics regarding problems with the dashboard..

Could you please be kind and put the steps that we need to follow, please DO NOT assume that we know the steps (because as you guess most of us we are still learning! and ENGLISH is not our first language I know that's not your fault, but try to explain a bit more please again search for lab 13.3 and you will see they are many post

now I tried to reinstall everything but I got tons of errors that I won't troubleshoot, I will probably leave this incomplete because I have no clue how to fix it .

I've tried to remove the deployment, but when I try to install it again it fails

instructions 1 to 4 are DEFINITELY not clear


  • chrispokorni
    chrispokorni Posts: 2,165

    The enrollment page for LFS258 - Kubernetes Fundamentals does list the following:

    Before starting this course, you should be familiar with:

    • Linux concepts and command line – We recommend Introduction to Linux, a free edX course
    • Package managers
    • Git and GitHub
    • We recommend Introduction to Kubernetes, a free edX course, as a good start for your Kubernetes journey

    For the dashboard installation, I encourage you to revisit Lab exercise 10.1 for helm installation steps, how to add a desired repository, fetch/pull and untar a chart, edit the values.yaml file of a chart, install and uninstall a release. These will be the steps needed for the kubernetes-dashboard installation.



Upcoming Training